summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkitgtk_2.12.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.12.3.bb')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.12.3.bb94
1 files changed, 94 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.12.3.bb b/meta/recipes-sato/webkit/webkitgtk_2.12.3.bb
new file mode 100644
index 0000000000..9a2387e81c
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk_2.12.3.bb
@@ -0,0 +1,94 @@
1SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "http://www.webkitgtk.org/"
3BUGTRACKER = "http://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebKit/LICENSE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
9 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
10 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
11 "
12
13SRC_URI = "\
14 http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
15 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
16 file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \
17 file://0001-OptionsGTK.cmake-drop-the-hardcoded-introspection-gt.patch \
18 file://0001-WebKitMacros-Append-to-I-and-not-to-isystem.patch \
19 file://musl-fixes.patch \
20 "
21SRC_URI[md5sum] = "aebb4029c09dd81664aa830e4a584c85"
22SRC_URI[sha256sum] = "173cbb9a2eca23eee52e99965483ab25aa9c0569ef5b57041fc0c129cc26c307"
23
24inherit cmake lib_package pkgconfig perlnative pythonnative distro_features_check upstream-version-is-even gobject-introspection
25
26# depends on libxt
27REQUIRED_DISTRO_FEATURES = "x11"
28
29DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libxt libidn gnutls \
30 gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \
31 pango icu bison-native gawk intltool-native libwebp \
32 atk udev harfbuzz jpeg libpng pulseaudio librsvg libtheora libvorbis libxcomposite libxtst \
33 ruby-native libnotify gstreamer1.0-plugins-bad \
34 "
35
36PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', 'wayland' ,d)} \
37 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'webgl', '' ,d)} \
38 enchant \
39 gtk2 \
40 libsecret \
41 "
42
43PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland"
44PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11"
45PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
46PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant"
47PACKAGECONFIG[gtk2] = "-DENABLE_PLUGIN_PROCESS_GTK2=ON,-DENABLE_PLUGIN_PROCESS_GTK2=OFF,gtk+"
48PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
49PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl"
50PACKAGECONFIG[libsecret] = "-DENABLE_CREDENTIAL_STORAGE=ON,-DENABLE_CREDENTIAL_STORAGE=OFF,libsecret"
51PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
52
53EXTRA_OECMAKE = " \
54 -DPORT=GTK \
55 -DCMAKE_BUILD_TYPE=Release \
56 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
57 -DENABLE_GTKDOC=OFF \
58 -DENABLE_MINIBROWSER=ON \
59 "
60
61# Javascript JIT is not supported on powerpc
62EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
63EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF "
64
65# ARM JIT code does not build on ARMv4/5/6 anymore
66EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF "
67EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF "
68EXTRA_OECMAKE_append_armv4 = " -DENABLE_JIT=OFF "
69
70# ARM JIT can build on armv7a, but doesnt' work on runtime, cause
71# displaying problems or ephiphany hang.
72EXTRA_OECMAKE_append_armv7a = " -DENABLE_JIT=OFF "
73
74# binutils 2.25.1 has a bug on aarch64:
75# https://sourceware.org/bugzilla/show_bug.cgi?id=18430
76EXTRA_OECMAKE_append_aarch64 = " -DUSE_LD_GOLD=OFF "
77
78# JIT not supported on MIPS either
79EXTRA_OECMAKE_append_mips = " -DENABLE_JIT=OFF "
80EXTRA_OECMAKE_append_mips64 = " -DENABLE_JIT=OFF "
81
82SECURITY_CFLAGS_remove_aarch64 = "-fpie"
83SECURITY_CFLAGS_append_aarch64 = " -fPIE"
84
85FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so"
86
87# http://errors.yoctoproject.org/Errors/Details/20370/
88ARM_INSTRUCTION_SET = "arm"
89
90# Invalid data memory access: 0x00000000
91# ...
92# qemu: uncaught target signal 11 (Segmentation fault) - core dumped
93# Segmentation fault
94EXTRA_OECMAKE_append_powerpc = " -DENABLE_INTROSPECTION=OFF "