summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkit-gtk_1.8.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/webkit/webkit-gtk_1.8.3.bb')
-rw-r--r--meta/recipes-sato/webkit/webkit-gtk_1.8.3.bb106
1 files changed, 106 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkit-gtk_1.8.3.bb b/meta/recipes-sato/webkit/webkit-gtk_1.8.3.bb
new file mode 100644
index 0000000000..920e1a0a76
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkit-gtk_1.8.3.bb
@@ -0,0 +1,106 @@
1SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "http://www.webkitgtk.org/"
3BUGTRACKER = "http://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/WebCore/rendering/RenderApplet.h;endline=22;md5=fb9694013ad71b78f8913af7a5959680 \
7 file://Source/WebKit/gtk/webkit/webkit.h;endline=21;md5=b4fbe9f4a944f1d071dba1d2c76b3351 \
8 file://Source/JavaScriptCore/parser/Parser.h;endline=23;md5=b57c8a2952a8d0e655988fa0ecb2bf7f"
9
10PR = "r1"
11
12# Choice of language backends - icu has issues on Big Endian machines so use pango
13ICU_LIB = "icu"
14ICU_LIB_powerpc = "pango"
15
16DEPENDS = "zlib enchant libsoup-2.4 curl libxml2 cairo libxslt libxt libidn gnutls \
17 gtk+ gstreamer gst-plugins-base flex-native gperf-native perl-native-runtime sqlite3 ${ICU_LIB}"
18DEPENDS += " ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl', '', d)}"
19
20SRC_URI = "\
21 http://www.webkitgtk.org/releases/webkit-${PV}.tar.xz \
22 file://nodolt.patch \
23 file://no-gtkdoc.patch \
24 file://webgit-gtk_fix_build_with_automake_1.12.patch \
25 file://bison-2.6.patch \
26 file://obsolete_automake_macros.patch \
27 file://0001-Enable-mips64-build.patch \
28 file://aarch64.patch \
29 "
30
31SRC_URI[md5sum] = "dcbf9d5e2e6391f857c29a57528b32a6"
32SRC_URI[sha256sum] = "ada02d636af61aed38f142d3cded662d141ce71264f624c4eb873621a74cc9e7"
33
34# webkit-gtk can NOT be built on MIPS64 with n32 ABI
35COMPATIBLE_HOST_mips64n32 = "null"
36
37inherit autotools lib_package gtk-doc pkgconfig
38
39S = "${WORKDIR}/webkit-${PV}/"
40
41EXTRA_OECONF = "\
42 --enable-debug=no \
43 --enable-svg \
44 --enable-icon-database=yes \
45 --enable-fullscreen-api \
46 --enable-image-resizer \
47 --enable-link-prefetch \
48 --with-gtk=2.0 \
49 --disable-geolocation \
50 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '--enable-webgl', '--disable-webgl', d)} \
51 UNICODE_CFLAGS=-D_REENTRANT \
52 "
53
54#default unicode backend icu breaks in cross-compile when target and host are different endian type
55EXTRA_OECONF_append_powerpc = " --with-unicode-backend=glib"
56
57CPPFLAGS_append_powerpc = " -I${STAGING_INCDIR}/pango-1.0 \
58 -I${STAGING_LIBDIR}/glib-2.0/include \
59 -I${STAGING_INCDIR}/glib-2.0"
60
61# ld can run out of memory linking libwebkitgtk!
62#
63LDFLAGS += "-Wl,--no-keep-memory"
64
65EXTRA_AUTORECONF = " -I Source/autotools "
66
67
68#| ./Source/JavaScriptCore/heap/HandleTypes.h: In static member function 'static T* JSC::HandleTypes<T>::getFromSlot(JSC::HandleSlot) [with T = JSC::Structure, JSC::HandleTypes<T>::ExternalType = JSC::Structure*, JSC::HandleSlot = JSC::JSValue*]':
69#| ./Source/JavaScriptCore/heap/Handle.h:141:79: instantiated from 'JSC::Handle<T>::ExternalType JSC::Handle<T>::get() const [with T = JSC::Structure, JSC::Handle<T>::ExternalType = JSC::Structure*]'
70#| ./Source/JavaScriptCore/runtime/ScopeChain.h:39:75: instantiated from here
71#| ./Source/JavaScriptCore/heap/HandleTypes.h:38:130: warning: cast from 'JSC::JSCell*' to 'JSC::HandleTypes<JSC::Structure>::ExternalType {aka JSC::Structure*}' increases required alignment of target type [-Wcast-align]
72#| {standard input}: Assembler messages:
73#| {standard input}:28873: Error: invalid immediate: 983040 is out of range
74#| {standard input}:28873: Error: value of 983040 too large for field of 2 bytes at 15110
75#| /OE/shr-core/tmp/sysroots/x86_64-linux/usr/libexec/armv4t-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.6.2/as: BFD (GNU Binutils) 2.21.1 assertion fail /OE/shr-core/tmp/work/armv4t-oe-linux-gnueabi/binutils-cross-2.21.1a-r0/binutils-2.21.1/bfd/elf.c:2819
76#| arm-oe-linux-gnueabi-g++: internal compiler error: Segmentation fault (program as)
77#| Please submit a full bug report,
78#| with preprocessed source if appropriate.
79#| See <http://gcc.gnu.org/bugs.html> for instructions.
80#| make[1]: *** [Source/JavaScriptCore/jit/libjavascriptcoregtk_1_0_la-JIT.lo] Error 1
81#| make[1]: Leaving directory `/OE/shr-core/tmp/work/armv4t-oe-linux-gnueabi/webkit-gtk-1.5.1+svnr90727-r0'
82ARM_INSTRUCTION_SET = "arm"
83
84CONFIGUREOPT_DEPTRACK = ""
85
86do_configure_append() {
87 # somethings wrong with icu, fix it up manually
88 for makefile in $(find ${B} -name "GNUmakefile") ; do
89 sed -i s:-I/usr/include::g $makefile
90 done
91}
92
93do_install_append() {
94 rmdir ${D}${libexecdir}
95}
96
97PACKAGES =+ "${PN}-webinspector ${PN}launcher-dbg ${PN}launcher libjavascriptcore"
98FILES_${PN}launcher = "${bindir}/GtkLauncher"
99FILES_${PN}launcher-dbg = "${bindir}/.debug/GtkLauncher"
100FILES_libjavascriptcore = "${libdir}/libjavascriptcoregtk-1.0.so.*"
101FILES_${PN}-webinspector = "${datadir}/webkitgtk-*/webinspector/"
102FILES_${PN} += "${datadir}/webkitgtk-*/resources/error.html \
103 ${datadir}/webkitgtk-*/images \
104 ${datadir}/glib-2.0/schemas"
105
106