summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb')
-rw-r--r--meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb b/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb
new file mode 100644
index 0000000000..ebdd6d123a
--- /dev/null
+++ b/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Provides an icon to shut down the system cleanly"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6SRC_URI = "file://shutdown.desktop"
7
8PR = "r1"
9
10S = "${WORKDIR}"
11
12do_install() {
13 install -d ${D}${datadir}/applications
14 install -m 0644 shutdown.desktop ${D}${datadir}/applications/
15
16 sed -i ${D}${datadir}/applications/shutdown.desktop -e 's#^Exec=\(.*\)#Exec=${base_sbindir}/\1#'
17}
18
19pkg_postinst_${PN} () {
20 grep -q qemuarm $D${sysconfdir}/hostname && \
21 sed -i $D${datadir}/applications/shutdown.desktop -e 's#^Exec=\(.*\)/halt#Exec=\1/reboot#' \
22 || true
23}
24
25inherit allarch