summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/settings-daemon/settings-daemon_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/settings-daemon/settings-daemon_svn.bb')
-rw-r--r--meta/recipes-sato/settings-daemon/settings-daemon_svn.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-sato/settings-daemon/settings-daemon_svn.bb b/meta/recipes-sato/settings-daemon/settings-daemon_svn.bb
new file mode 100644
index 0000000000..4d1d9baf40
--- /dev/null
+++ b/meta/recipes-sato/settings-daemon/settings-daemon_svn.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Settings-daemon provides a bridge between gconf and xsettings"
2HOMEPAGE = "http://svn.o-hand.com/view/matchbox/trunk/settings-daemon/"
3BUGTRACKER = "http://bugzilla.openedhand.com/"
4LICENSE = "MIT-style"
5LIC_FILES_CHKSUM = "file://xsettings-manager.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
6 file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b"
7DEPENDS = "gconf glib-2.0 gtk+"
8SECTION = "x11"
9PV = "0.0+svnr${SRCREV}"
10
11PR = "r3"
12
13SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
14 file://addsoundkeys.patch;apply=yes \
15 file://70settings-daemon.sh"
16
17S = "${WORKDIR}/${PN}"
18
19inherit autotools pkgconfig gconf
20
21FILES_${PN} = "${bindir}/* ${sysconfdir}"
22
23do_install_append () {
24 install -d ${D}/${sysconfdir}/X11/Xsession.d
25 install -m 755 ${WORKDIR}/70settings-daemon.sh ${D}/${sysconfdir}/X11/Xsession.d/
26}