summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb')
-rw-r--r--meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb b/meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb
new file mode 100644
index 0000000000..f3305aef78
--- /dev/null
+++ b/meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Ultra-simple screen capture utility, aimed at handheld devices"
2HOMEPAGE = "http://www.o-hand.com"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://main.c;endline=9;md5=023e14d6404d0a961eb97cbd011fc141 \
8 file://screenshot-ui.h;endline=9;md5=638d9ffa83e9325a36df224166ed6ad0"
9
10DEPENDS = "matchbox-panel-2 gtk+3"
11
12# SRCREV tagged 0.3
13SRCREV = "9250fa5a012d84ff45984e8c4345ee7635227756"
14SRC_URI = "git://git.yoctoproject.org/screenshot"
15UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
16
17S = "${WORKDIR}/git"
18
19inherit autotools pkgconfig distro_features_check
20
21FILES_${PN} += "${libdir}/matchbox-panel/*.so"
22
23do_install_append () {
24 rm ${D}${libdir}/matchbox-panel/*.la
25}
26
27# The matchbox-panel-2 requires x11 in DISTRO_FEATURES
28REQUIRED_DISTRO_FEATURES = "x11"