summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb')
-rw-r--r--meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb b/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb
new file mode 100644
index 0000000000..ced735f001
--- /dev/null
+++ b/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Sato icon theme"
2HOMEPAGE = "http://www.o-hand.com"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4
5LICENSE = "CC-BY-SA-3.0"
6LIC_FILES_CHKSUM = "file://COPYING;md5=56a830bbe6e4697fe6cbbae01bb7c2b2"
7SECTION = "x11"
8
9PR = "r6"
10
11DEPENDS = "icon-naming-utils-native libxml-simple-perl-native"
12
13SRC_URI = "http://pokylinux.org/releases/sato/${BPN}-${PV}.tar.gz \
14 file://0001-Inherit-the-GNOME-icon-theme.patch"
15
16SRC_URI[md5sum] = "86a847f3128a43a9cf23b7029a656f50"
17SRC_URI[sha256sum] = "0b0a2807a6a96918ac799a86094ec3e8e2c892be0fd679a4232c2a77f2f61732"
18
19inherit autotools pkgconfig allarch gtk-icon-cache perlnative
20
21# The configure script uses pkg-config to find native binaries to execute, so
22# tell it to use our pkg-config-native wrapper.
23export PKG_CONFIG = "pkg-config-native"
24
25FILES_${PN} += "${datadir}/icons/Sato"
26
27do_install_append() {
28 find ${D}${datadir}/icons/Sato/ -maxdepth 1 -type d -exec ln -s preferences-system.png {}/apps/preferences-desktop.png \;
29 find ${D}${datadir}/icons/Sato/ -maxdepth 1 -type d -exec ln -s file-manager.png {}/apps/system-file-manager.png \;
30 find ${D}${datadir}/icons/Sato/ -maxdepth 1 -type d -exec ln -s ../apps/terminal.png {}/places/computer.png \;
31}
32
33# Explictly setting "Sato" as the default icon theme to avoid flickering from
34# the desktop and settings daemon racing. This shouldn't be done here but in the sato image
35pkg_postinst_${PN} () {
36 mkdir -p $D/etc/gtk-2.0
37
38 grep -s -q -e ^gtk-icon-theme-name.*\"Sato\" $D/etc/gtk-2.0/gtkrc || \
39 echo 'gtk-icon-theme-name = "Sato"' >> $D/etc/gtk-2.0/gtkrc
40}