summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.20.bb')
-rw-r--r--meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.20.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.20.bb b/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.20.bb
new file mode 100644
index 0000000000..3a1ea6633b
--- /dev/null
+++ b/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.20.bb
@@ -0,0 +1,65 @@
1SECTION = "x11/utils"
2SUMMARY = "rxvt terminal clone supporting unicode"
3DESCRIPTION = "rxvt-unicode is a clone of the well known \
4terminal emulator rxvt, modified to store text in Unicode \
5(either UCS-2 or UCS-4) and to use locale-correct input and \
6output. It also supports mixing multiple fonts at the \
7same time, including Xft fonts."
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
10 file://src/main.C;beginline=1;endline=31;md5=775485398a09fa7aee6f90464af88432"
11
12DEPENDS = "virtual/libx11 libxt libxft gdk-pixbuf"
13
14SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
15 file://xwc.patch \
16 file://rxvt.desktop \
17 file://rxvt.png"
18
19SRC_URI[md5sum] = "4a5b823f08d21036f94a6c51e94d025b"
20SRC_URI[sha256sum] = "e73e13fe64b59fd3c8e6e20c00f149d388741f141b8155e4700d3ed40aa94b4e"
21
22inherit autotools update-alternatives
23
24PROVIDES = "virtual/x-terminal-emulator"
25ALTERNATIVE_${PN} = "x-terminal-emulator"
26ALTERNATIVE_TARGET[x-terminal-emulator] = "${bindir}/rxvt"
27
28CFLAGS_append = " -fpermissive"
29
30EXTRA_OECONF = "--enable-menubar --enable-xim \
31 --enable-utmp --enable-wtmp --enable-lastlog \
32 --disable-strings --with-term=rxvt --enable-keepscrolling \
33 --enable-xft --with-name=rxvt --enable-frills \
34 --enable-swapscreen --enable-transparency \
35 --with-codesets=eu \
36 --enable-cursor-blink --enable-pointer-blank \
37 --enable-text-blink --enable-rxvt-scroll \
38 --enable-combining --enable-shared \
39 --enable-xgetdefault \
40 --disable-perl \
41 --with-x=${STAGING_DIR_HOST}${prefix}"
42
43do_configure_prepend () {
44 if [ ! -e ${S}/acinclude.m4 ]; then
45 cp ${S}/aclocal.m4 ${S}/acinclude.m4
46 fi
47}
48
49do_compile_prepend () {
50 echo '#define UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
51 echo '#define WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
52 echo '#define LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
53 echo '#define HAVE_XLOCALE 1' >> config.h
54}
55
56do_install_append () {
57 install -d ${D}/${datadir}
58 install -d ${D}/${datadir}/applications
59 install -d ${D}/${datadir}/pixmaps/
60
61 install -m 0644 ${WORKDIR}/rxvt.png ${D}/${datadir}/pixmaps
62 install -m 0644 ${WORKDIR}/rxvt.desktop ${D}/${datadir}/applications
63}
64
65FILES_${PN} += "${datadir}/applications/rxvt.desktop ${datadir}/pixmaps/rxvt.png"