summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.19.bb')
-rw-r--r--meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.19.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.19.bb b/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.19.bb
new file mode 100644
index 0000000000..c67adbb602
--- /dev/null
+++ b/meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.19.bb
@@ -0,0 +1,64 @@
1SECTION = "x11/utils"
2DESCRIPTION = "rxvt-unicode is a clone of the well known \
3terminal emulator rxvt, modified to store text in Unicode \
4(either UCS-2 or UCS-4) and to use locale-correct input and \
5output. It also supports mixing multiple fonts at the \
6same time, including Xft fonts."
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
9 file://src/main.C;beginline=1;endline=31;md5=775485398a09fa7aee6f90464af88432"
10
11DEPENDS = "virtual/libx11 libxt libxft gdk-pixbuf"
12
13SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
14 file://xwc.patch \
15 file://rxvt.desktop \
16 file://rxvt.png"
17
18SRC_URI[md5sum] = "45ad197eb9b5a840c0f65e3a8131921c"
19SRC_URI[sha256sum] = "d9237cf1973af461ecbeeb708e4d00893294771558e8338b4f33418ed52d3241"
20
21inherit autotools update-alternatives
22
23PROVIDES = "virtual/x-terminal-emulator"
24ALTERNATIVE_${PN} = "x-terminal-emulator"
25ALTERNATIVE_TARGET[x-terminal-emulator] = "${bindir}/rxvt"
26
27CFLAGS_append = " -fpermissive"
28
29EXTRA_OECONF = "--enable-menubar --enable-xim \
30 --enable-utmp --enable-wtmp --enable-lastlog \
31 --disable-strings --with-term=rxvt --enable-keepscrolling \
32 --enable-xft --with-name=rxvt --enable-frills \
33 --enable-swapscreen --enable-transparency \
34 --with-codesets=eu \
35 --enable-cursor-blink --enable-pointer-blank \
36 --enable-text-blink --enable-rxvt-scroll \
37 --enable-combining --enable-shared \
38 --enable-xgetdefault \
39 --disable-perl \
40 --with-x=${STAGING_DIR_HOST}${prefix}"
41
42do_configure_prepend () {
43 if [ ! -e ${S}/acinclude.m4 ]; then
44 cp ${S}/aclocal.m4 ${S}/acinclude.m4
45 fi
46}
47
48do_compile_prepend () {
49 echo '#define UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
50 echo '#define WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
51 echo '#define LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
52 echo '#define HAVE_XLOCALE 1' >> config.h
53}
54
55do_install_append () {
56 install -d ${D}/${datadir}
57 install -d ${D}/${datadir}/applications
58 install -d ${D}/${datadir}/pixmaps/
59
60 install -m 0644 ${WORKDIR}/rxvt.png ${D}/${datadir}/pixmaps
61 install -m 0644 ${WORKDIR}/rxvt.desktop ${D}/${datadir}/applications
62}
63
64FILES_${PN} += "${datadir}/applications/rxvt.desktop ${datadir}/pixmaps/rxvt.png"