summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/puzzles/puzzles_r10286.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/puzzles/puzzles_r10286.bb')
-rw-r--r--meta/recipes-sato/puzzles/puzzles_r10286.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_r10286.bb b/meta/recipes-sato/puzzles/puzzles_r10286.bb
new file mode 100644
index 0000000000..1ad8d1bf14
--- /dev/null
+++ b/meta/recipes-sato/puzzles/puzzles_r10286.bb
@@ -0,0 +1,59 @@
1SUMMARY = "Simon Tatham's Portable Puzzle Collection"
2HOMEPAGE = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
3
4DEPENDS = "gtk+ libxt"
5MOD_PV = "${@d.getVar('PV',1)[1:]}"
6
7# The libxt requires x11 in DISTRO_FEATURES
8REQUIRED_DISTRO_FEATURES = "x11"
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENCE;md5=33bcd4bce8f3c197f2aefbdbd2d299bc"
12
13SRC_URI = "svn://svn.tartarus.org/sgt;module=puzzles;rev=${MOD_PV} \
14 file://fix-compiling-failure-with-option-g-O.patch \
15 file://puzzles_x32_abi_time.patch \
16"
17
18S = "${WORKDIR}/${BPN}"
19
20inherit autotools-brokensep distro_features_check
21
22do_configure_prepend () {
23 ./mkfiles.pl
24}
25
26FILES_${PN} = "${prefix}/bin/* ${datadir}/applications/*"
27FILES_${PN}-dbg += "${prefix}/bin/.debug"
28
29do_install () {
30 rm -rf ${D}/*
31 export prefix=${D}
32 export DESTDIR=${D}
33 install -d ${D}/${prefix}/bin/
34 oe_runmake install
35
36
37 install -d ${D}/${datadir}/applications/
38
39 # Create desktop shortcuts
40 cd ${D}/${prefix}/bin
41 for prog in *; do
42 if [ -x $prog ]; then
43 # Convert prog to Title Case
44 title=$(echo $prog | sed 's/\(^\| \)./\U&/g')
45 echo "making ${D}/${datadir}/applications/$prog.desktop"
46 cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
47[Desktop Entry]
48Name=$title
49Exec=${prefix}/bin/$prog
50Icon=applications-games
51Terminal=false
52Type=Application
53Categories=Game;
54StartupNotify=true
55X-MB-SingleInstance=true
56STOP
57 fi
58 done
59}