summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/puzzles/puzzles_r10116.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/puzzles/puzzles_r10116.bb')
-rw-r--r--meta/recipes-sato/puzzles/puzzles_r10116.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_r10116.bb b/meta/recipes-sato/puzzles/puzzles_r10116.bb
new file mode 100644
index 0000000000..6ee4d962b2
--- /dev/null
+++ b/meta/recipes-sato/puzzles/puzzles_r10116.bb
@@ -0,0 +1,55 @@
1SUMMARY = "Simon Tatham's Portable Puzzle Collection"
2HOMEPAGE = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
3
4DEPENDS = "gtk+ libxt"
5MOD_PV = "${@d.getVar('PV',1)[1:]}"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENCE;md5=33bcd4bce8f3c197f2aefbdbd2d299bc"
9
10SRC_URI = "svn://svn.tartarus.org/sgt;module=puzzles;rev=${MOD_PV} \
11 file://fix-compiling-failure-with-option-g-O.patch \
12"
13
14S = "${WORKDIR}/${BPN}"
15
16inherit autotools-brokensep
17
18do_configure_prepend () {
19 ./mkfiles.pl
20}
21
22FILES_${PN} = "${prefix}/bin/* ${datadir}/applications/*"
23FILES_${PN}-dbg += "${prefix}/bin/.debug"
24
25do_install () {
26 rm -rf ${D}/*
27 export prefix=${D}
28 export DESTDIR=${D}
29 install -d ${D}/${prefix}/bin/
30 oe_runmake install
31
32
33 install -d ${D}/${datadir}/applications/
34
35 # Create desktop shortcuts
36 cd ${D}/${prefix}/bin
37 for prog in *; do
38 if [ -x $prog ]; then
39 # Convert prog to Title Case
40 title=$(echo $prog | sed 's/\(^\| \)./\U&/g')
41 echo "making ${D}/${datadir}/applications/$prog.desktop"
42 cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
43[Desktop Entry]
44Name=$title
45Exec=${prefix}/bin/$prog
46Icon=applications-games
47Terminal=false
48Type=Application
49Categories=Game;
50StartupNotify=true
51X-MB-SingleInstance=true
52STOP
53 fi
54 done
55}