summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/pcmanfm/pcmanfm_1.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/pcmanfm/pcmanfm_1.1.2.bb')
-rw-r--r--meta/recipes-sato/pcmanfm/pcmanfm_1.1.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-sato/pcmanfm/pcmanfm_1.1.2.bb b/meta/recipes-sato/pcmanfm/pcmanfm_1.1.2.bb
new file mode 100644
index 0000000000..14c5cd5d63
--- /dev/null
+++ b/meta/recipes-sato/pcmanfm/pcmanfm_1.1.2.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Fast lightweight tabbed filemanager"
2HOMEPAGE = "http://pcmanfm.sourceforge.net/"
3
4LICENSE = "GPLv2 & GPLv2+ & LGPLv2.1+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
6 file://src/pcmanfm.h;endline=22;md5=417b3855771a3a87f8ad753d994491f0 \
7 file://src/gseal-gtk-compat.h;endline=21;md5=46922c8691f58d124f9420fe16149ce2"
8
9SECTION = "x11"
10DEPENDS = "gtk+ startup-notification libfm intltool-native"
11DEPENDS_append_poky = " libowl"
12
13
14COMPATIBLE_HOST = '(x86_64.*|i.86.*|aarch64.*|arm.*|mips.*|powerpc.*|sh.*)-(linux|freebsd.*)'
15
16SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/pcmanfm-${PV}.tar.gz \
17 file://gnome-fs-directory.png \
18 file://gnome-fs-regular.png \
19 file://gnome-mime-text-plain.png \
20 file://emblem-symbolic-link.png \
21 file://no-desktop.patch"
22
23SRC_URI[md5sum] = "41104699e653ff2b0a9a9e80a257d6a2"
24SRC_URI[sha256sum] = "23ee33b34066ac83ce9a98bc9930049e69839438fb60489bd453bec8c2068950"
25
26inherit autotools pkgconfig
27
28do_install_append () {
29 install -d ${D}/${datadir}
30 install -d ${D}/${datadir}/pixmaps/
31
32 install -m 0644 ${WORKDIR}/*.png ${D}/${datadir}/pixmaps
33}