summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb')
-rw-r--r--meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb b/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
new file mode 100644
index 0000000000..4ec5e8961c
--- /dev/null
+++ b/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
@@ -0,0 +1,68 @@
1#
2# Copyright (C) 2007-2008 OpenedHand Ltd.
3#
4
5SUMMARY = "Sato desktop"
6LICENSE = "MIT"
7PR = "r33"
8
9inherit packagegroup
10
11PACKAGE_ARCH = "${MACHINE_ARCH}"
12
13PACKAGES = "${PN} ${PN}-base ${PN}-apps ${PN}-games"
14
15# For backwards compatibility after rename
16RPROVIDES_${PN} = "task-core-x11-sato"
17RREPLACES_${PN} = "task-core-x11-sato"
18RCONFLICTS_${PN} = "task-core-x11-sato"
19
20RDEPENDS_${PN} = "\
21 ${PN}-base \
22 ${PN}-apps \
23 ${PN}-games \
24 "
25
26NETWORK_MANAGER ?= "connman-gnome"
27NETWORK_MANAGER_libc-uclibc = ""
28
29SUMMARY_${PN}-base = "Sato desktop - base packages"
30RDEPENDS_${PN}-base = "\
31 matchbox-desktop \
32 matchbox-session-sato \
33 matchbox-keyboard \
34 matchbox-keyboard-applet \
35 matchbox-keyboard-im \
36 matchbox-config-gtk \
37 xcursor-transparent-theme \
38 sato-icon-theme \
39 settings-daemon \
40 gtk-sato-engine \
41 shutdown-desktop \
42 libsdl \
43 ${NETWORK_MANAGER} \
44 udev-extraconf \
45 "
46
47# pcmanfm doesn't work on mips
48FILEMANAGER ?= "pcmanfm"
49FILEMANAGER_mips ?= ""
50
51WEB ?= ""
52#WEB = "midori"
53
54SUMMARY_${PN}-apps = "Sato desktop - applications"
55RDEPENDS_${PN}-apps = "\
56 leafpad \
57 gaku \
58 x11vnc \
59 matchbox-terminal \
60 sato-screenshot \
61 ${FILEMANAGER} \
62 ${WEB} \
63 "
64
65SUMMARY_${PN}-games = "Sato desktop - games"
66RDEPENDS_${PN}-games = "\
67 oh-puzzles \
68 "