summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/midori/midori_0.5.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/midori/midori_0.5.8.bb')
-rw-r--r--meta/recipes-sato/midori/midori_0.5.8.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-sato/midori/midori_0.5.8.bb b/meta/recipes-sato/midori/midori_0.5.8.bb
new file mode 100644
index 0000000000..3aabdd4385
--- /dev/null
+++ b/meta/recipes-sato/midori/midori_0.5.8.bb
@@ -0,0 +1,26 @@
1SUMMARY = "A lightweight web browser"
2HOMEPAGE = "http://midori-browser.org/"
3LICENSE = "LGPLv2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
5DEPENDS = "webkit-gtk libsoup-2.4 openssl python-native python-docutils-native librsvg-native libnotify libxscrnsaver"
6
7SRC_URI = "https://launchpad.net/midori/trunk/0.5.8/+download/${BPN}-${PV}.tar.bz2;subdir=${BPN}-${PV}"
8SRC_URI[md5sum] = "b89e25e74199d705e74767499a415976"
9SRC_URI[sha256sum] = "af19135fd4c4b04345df4d3592e7939c20f9b40eaca24550e6cb619751aa9381"
10
11# midori depends on webkit-gtk, and webkit-gtk can NOT be built on
12# MIPS64 with n32 ABI. So remove it from mips64 n32 temporarily.
13COMPATIBLE_HOST_mips64n32 = "null"
14
15inherit gtk-icon-cache pkgconfig vala pythonnative cmake
16
17EXTRA_OECMAKE = " \
18 -DCMAKE_INSTALL_PREFIX=${prefix} \
19 -DUSE_ZEITGEIST=0 \
20"
21
22TARGET_CC_ARCH += "${LDFLAGS}"
23
24RRECOMMENDS_${PN} += "glib-networking ca-certificates gnome-icon-theme"
25
26FILES_${PN} += "${datadir}/appdata"