summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb')
-rw-r--r--meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb b/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
new file mode 100644
index 0000000000..fe84a0fc99
--- /dev/null
+++ b/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Custom Matchbox session files for the Sato environment"
2HOMEPAGE = "http://www.matchbox-project.org/"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4
5LICENSE = "GPLv2.0+"
6LIC_FILES_CHKSUM = "file://session;endline=3;md5=f8a5c5b9c279e52dc094d10e11c2be63"
7
8SECTION = "x11"
9DEPENDS = "gconf-native"
10RDEPENDS_${PN} = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato matchbox-session gconf"
11PR = "r30"
12
13# This package is architecture specific because the session script is modified
14# based on the machine architecture.
15PACKAGE_ARCH = "${MACHINE_ARCH}"
16
17SRC_URI = "file://session"
18S = "${WORKDIR}"
19
20do_install() {
21 # This is the set of machine features that the script has markers for
22 FEATURES="phone"
23 SCRIPT="${S}/sedder"
24 rm -f $SCRIPT
25 touch $SCRIPT
26 for FEAT in $FEATURES; do
27 if echo ${MACHINE_FEATURES} | awk "/$FEAT/ {exit 1}"; then
28 echo "/feature-$FEAT/d" >> $SCRIPT
29 fi
30 done
31
32 install -d ${D}/${sysconfdir}/matchbox
33 sed -f "$SCRIPT" ${S}/session > ${D}/${sysconfdir}/matchbox/session
34 chmod +x ${D}/${sysconfdir}/matchbox/session
35}
36
37pkg_postinst_${PN} () {
38 set_value() {
39 #type, name, value
40 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type $1 --set /desktop/poky/interface/$2 "$3"
41 }
42 set_value string theme Sato
43 set_value string icon_theme Sato
44 set_value bool touchscreen true
45 set_value string font_name "Sans 9"
46}