summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb')
-rw-r--r--meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb
new file mode 100644
index 0000000000..490e2bc86b
--- /dev/null
+++ b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Simple GTK+ based panel for handheld devices"
2HOMEPAGE = "http://matchbox-project.org"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://matchbox-panel/mb-panel.h;endline=10;md5=0b7db28f4b6863fb853d0467e590019a \
8 file://applets/startup/startup.c;endline=22;md5=b0a64fbef3097d79f8264e6907a98f03"
9
10DEPENDS = "gnome-common gtk+ startup-notification dbus dbus-glib"
11DEPENDS += " ${@bb.utils.contains("MACHINE_FEATURES", "acpi", "libacpi", "",d)}"
12DEPENDS += " ${@bb.utils.contains("MACHINE_FEATURES", "apm", "apmd", "",d)}"
13
14SRCREV = "26a3a67b41c50e0ae163d8fe86ccf7a0f0a671ae"
15PV = "2.0+git${SRCPV}"
16
17RPROVIDES_${PN} = "matchbox-panel"
18RREPLACES_${PN} = "matchbox-panel"
19RCONFLICTS_${PN} = "matchbox-panel"
20
21SRC_URI = "git://git.yoctoproject.org/${BPN} \
22 file://silence-warnings.patch"
23
24EXTRA_OECONF = "--enable-startup-notification --enable-dbus"
25EXTRA_OECONF += " ${@bb.utils.contains("MACHINE_FEATURES", "acpi", "--with-battery=acpi", "",d)}"
26EXTRA_OECONF += " ${@bb.utils.contains("MACHINE_FEATURES", "apm", "--with-battery=apm", "",d)}"
27
28S = "${WORKDIR}/git"
29
30FILES_${PN} += "${libdir}/matchbox-panel/*.so \
31 ${datadir}/matchbox-panel/brightness/*.png \
32 ${datadir}/matchbox-panel/startup/*.png "
33FILES_${PN}-dbg += "${libdir}/matchbox-panel/.debug"
34FILES_${PN}-dev += "${libdir}/matchbox-panel/*.la"
35
36inherit autotools pkgconfig