summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.2.bb')
-rw-r--r--meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.2.bb34
1 files changed, 0 insertions, 34 deletions
diff --git a/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.2.bb b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.2.bb
deleted file mode 100644
index b05a9c48ad..0000000000
--- a/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.2.bb
+++ /dev/null
@@ -1,34 +0,0 @@
1SUMMARY = "Matchbox Window Manager Desktop"
2DESCRIPTION = "A lightweight windows manager for embedded systems. It uses the desktop background to provide an application launcher and allows modules to be loaded for additional functionality."
3HOMEPAGE = "http://matchbox-project.org/"
4BUGTRACKER = "http://bugzilla.yoctoproject.org/"
5
6LICENSE = "GPL-2.0-or-later & LGPL-2.0-or-later"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://src/desktop.c;endline=20;md5=36c9bf295e6007f3423095f405af5a2d \
9 file://src/main.c;endline=19;md5=2044244f97a195c25b7dc602ac7e9a00"
10
11DEPENDS = "gtk+3 startup-notification dbus"
12SECTION = "x11/wm"
13
14# SRCREV tagged 2.2
15SRCREV = "6bc67d09da4147e5552fe30011a05a2c59d2f777"
16SRC_URI = "git://git.yoctoproject.org/${BPN}-2;branch=master \
17 file://vfolders/ \
18 "
19
20EXTRA_OECONF = "--enable-startup-notification --with-dbus"
21
22S = "${WORKDIR}/git"
23
24inherit autotools pkgconfig features_check
25
26# The startup-notification requires x11 in DISTRO_FEATURES
27REQUIRED_DISTRO_FEATURES = "x11"
28
29do_install:append() {
30 install -d ${D}${datadir}/matchbox/vfolders/
31 install -m 0644 ${WORKDIR}/vfolders/* ${D}${datadir}/matchbox/vfolders/
32}
33
34FILES:${PN} += "${datadir}/matchbox/vfolders/"