summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/leafpad/leafpad_0.8.18.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/leafpad/leafpad_0.8.18.1.bb')
-rw-r--r--meta/recipes-sato/leafpad/leafpad_0.8.18.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-sato/leafpad/leafpad_0.8.18.1.bb b/meta/recipes-sato/leafpad/leafpad_0.8.18.1.bb
new file mode 100644
index 0000000000..830c053b6b
--- /dev/null
+++ b/meta/recipes-sato/leafpad/leafpad_0.8.18.1.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Simple GTK+ Text Editor"
2HOMEPAGE = "http://tarot.freeshell.org/leafpad/"
3
4LICENSE = "GPLv2 & GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
6 file://src/leafpad.h;endline=20;md5=d3d6a89f5e61e8b13bdea537511ba1fa \
7 file://src/utils.c;endline=20;md5=0d2cc6584ba3202448bb274f62739571"
8
9DEPENDS = "gtk+ intltool-native"
10DEPENDS_append_poky = " libowl"
11SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz \
12 file://leafpad.desktop"
13
14SRC_URI[md5sum] = "254a72fc67505e3aa52884c729cd7b97"
15SRC_URI[sha256sum] = "959d22ae07f22803bc66ff40d373a854532a6e4732680bf8a96a3fbcb9f80a2c"
16PR = "r2"
17
18SRC_URI_append_poky = " file://owl-menu.patch;apply=yes "
19
20inherit autotools pkgconfig
21
22EXTRA_OECONF = " --enable-chooser --disable-emacs --disable-print"
23
24do_install_append () {
25 install -d ${D}/${datadir}
26 install -d ${D}/${datadir}/applications
27 install -m 0644 ${WORKDIR}/leafpad.desktop ${D}/${datadir}/applications
28}
29
30FILES_${PN} += "${datadir}/applications/leafpad.desktop"
31
32PACKAGES += "leafpad-stock-icons"
33FILES_leafpad-stock-icons = "${datadir}/icons/hicolor/"