summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/images/core-image-sato-sdk-ptest.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/images/core-image-sato-sdk-ptest.bb')
-rw-r--r--meta/recipes-sato/images/core-image-sato-sdk-ptest.bb27
1 files changed, 0 insertions, 27 deletions
diff --git a/meta/recipes-sato/images/core-image-sato-sdk-ptest.bb b/meta/recipes-sato/images/core-image-sato-sdk-ptest.bb
deleted file mode 100644
index eea89a5d6c..0000000000
--- a/meta/recipes-sato/images/core-image-sato-sdk-ptest.bb
+++ /dev/null
@@ -1,27 +0,0 @@
1inherit features_check
2REQUIRED_DISTRO_FEATURES = "ptest"
3
4require core-image-sato-sdk.bb
5require conf/distro/include/ptest-packagelists.inc
6
7DESCRIPTION += "Also includes ptest packages."
8HOMEPAGE = "https://www.yoctoproject.org/"
9
10PROVIDES += "core-image-sato-ptest"
11
12# Also include ptests which may not otherwise be included in a sato image
13IMAGE_INSTALL += "${PTESTS_FAST} ${PTESTS_SLOW}"
14
15# This image is sufficiently large (~1.8GB) that we need to be careful that it fits in a live
16# image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
17# box) and explicitly add just 1100MB.
18# strace-ptest in particular needs more than 500MB
19IMAGE_OVERHEAD_FACTOR = "1.0"
20IMAGE_ROOTFS_EXTRA_SPACE = "1124288"
21
22# ptests need more memory than standard to avoid the OOM killer
23# also lttng-tools needs /tmp that has at least 1G
24QB_MEM = "-m 2048"
25
26# Sadly at the moment the full set of ptests is not robust enough and sporadically fails in random places
27PTEST_EXPECT_FAILURE = "1"