summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/rt-tests_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-rt/rt-tests/rt-tests_git.bb')
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_git.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests_git.bb b/meta/recipes-rt/rt-tests/rt-tests_git.bb
new file mode 100644
index 0000000000..ef082131e2
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/rt-tests_git.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Real-Time preemption testcases"
2HOMEPAGE = "https://wiki.linuxfoundation.org/realtime/documentation/start"
3DESCRIPTION = "The main aim of the PREEMPT_RT patch is to minimize the amount of kernel code that is non-preemptible Therefore several substitution mechanisms and new mechanisms are implemented."
4SECTION = "tests"
5DEPENDS = "linux-libc-headers virtual/libc numactl"
6LICENSE = "GPL-2.0-only & GPL-2.0-or-later"
7LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
8
9require rt-tests.inc
10inherit ptest
11
12SRC_URI += " \
13 file://run-ptest \
14 file://rt_bmark.py \
15 file://0001-Makefile-Allow-for-CC-and-AR-to-be-overridden.patch \
16 "
17
18# rt-tests needs PI mutex support in libc
19COMPATIBLE_HOST:libc-musl = 'null'
20
21# Do not install hwlatdetect
22EXTRA_OEMAKE += "PYLIB=''"
23
24do_install() {
25 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
26 INCLUDEDIR=${includedir}
27}
28
29do_install_ptest() {
30 cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
31}
32
33RDEPENDS:${PN}-ptest += " stress-ng python3 python3-multiprocessing python3-datetime python3-misc"
34
35FILES:${PN} += "${prefix}/src/backfire"
36RDEPENDS:${PN} += "bash"