summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt-apps/fotowall_0.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-qt/qt-apps/fotowall_0.9.bb')
-rw-r--r--meta/recipes-qt/qt-apps/fotowall_0.9.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-qt/qt-apps/fotowall_0.9.bb b/meta/recipes-qt/qt-apps/fotowall_0.9.bb
new file mode 100644
index 0000000000..48dcc02e2a
--- /dev/null
+++ b/meta/recipes-qt/qt-apps/fotowall_0.9.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Creative photo display application"
2DESCRIPTION = "Fotowall is a creative tool that allows you to layout your photos or pictures \
3in a personal way. You can add pictures, then resize, move, change colors, text, shadows, etc.."
4
5HOMEPAGE = "http://www.enricoros.com/opensource/fotowall"
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://GPL_V2;md5=79808397c3355f163c012616125c9e26 \
8 file://main.cpp;beginline=6;endline=11;md5=b569acc2bf8974a3082b58fc53b9d8dc"
9SECTION = "x11/apps"
10
11PR = "r4"
12
13SRC_URI = "http://qt-apps.org/CONTENT/content-files/71316-Fotowall-0.9.tar.bz2 \
14 file://ExportWizard-depends-on-ui_wizard.patch \
15 "
16
17SRC_URI[md5sum] = "142ef697332e0777c6d22c5bc96cc438"
18SRC_URI[sha256sum] = "e4d0c005d2cb1d7c09438bfc3098eadebc08946e4fbc0655b7fc8b046de3810d"
19
20S = "${WORKDIR}/Fotowall-${PV}"
21
22inherit qt4x11
23
24EXTRA_QMAKEVARS_PRE = "CONFIG+=no-webcam"
25
26do_install() {
27 oe_runmake INSTALL_ROOT=${D} install
28}
29
30# Ensure we have some plugins for some useful image formats
31RRECOMMENDS_${PN} += "qt4-plugin-imageformat-gif qt4-plugin-imageformat-jpeg qt4-plugin-imageformat-tiff"