summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/mpg123/mpg123_1.24.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/mpg123/mpg123_1.24.0.bb')
-rw-r--r--meta/recipes-multimedia/mpg123/mpg123_1.24.0.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/mpg123/mpg123_1.24.0.bb b/meta/recipes-multimedia/mpg123/mpg123_1.24.0.bb
new file mode 100644
index 0000000000..587327b9ef
--- /dev/null
+++ b/meta/recipes-multimedia/mpg123/mpg123_1.24.0.bb
@@ -0,0 +1,57 @@
1SUMMARY = "Audio decoder for MPEG-1 Layer 1/2/3"
2DESCRIPTION = "The core of mpg123 is an MPEG-1 Layer 1/2/3 decoding library, which can be used by other programs. \
3mpg123 also comes with a command-line tool which can playback using ALSA, PulseAudio, OSS, and several other APIs, \
4and also can write the decoded audio to WAV."
5HOMEPAGE = "http://mpg123.de/"
6BUGTRACKER = "http://sourceforge.net/p/mpg123/bugs/"
7SECTION = "multimedia"
8
9LICENSE = "LGPLv2.1"
10LICENSE_FLAGS = "commercial"
11LIC_FILES_CHKSUM = "file://COPYING;md5=1e86753638d3cf2512528b99079bc4f3"
12
13SRC_URI = "https://www.mpg123.de/download/${BP}.tar.bz2"
14
15SRC_URI[md5sum] = "75d62ac0cb713a7bac5af4ded4af2bb4"
16SRC_URI[sha256sum] = "55fb169a7711938f5df0497d1ffe28419fbef50011dc01d00b216379e6a2256c"
17
18inherit autotools pkgconfig
19
20# The options should be mutually exclusive for configuration script.
21# If both alsa and pulseaudio are specified (as in the default distro features)
22# pulseaudio takes precedence.
23PACKAGECONFIG_ALSA = "${@bb.utils.filter('DISTRO_FEATURES', 'alsa', d)}"
24PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '${PACKAGECONFIG_ALSA}', d)}"
25
26PACKAGECONFIG[alsa] = "--with-default-audio=alsa,,alsa-lib"
27PACKAGECONFIG[esd] = ",,esound"
28PACKAGECONFIG[jack] = ",,jack"
29PACKAGECONFIG[openal] = ",,openal-soft"
30PACKAGECONFIG[portaudio] = ",,portaudio-v19"
31PACKAGECONFIG[pulseaudio] = "--with-default-audio=pulse,,pulseaudio"
32PACKAGECONFIG[sdl] = ",,libsdl"
33
34# Following are possible sound output modules:
35# alsa arts coreaudio dummy esd jack nas openal os2 oss portaudio pulse sdl sndio sun tinyalsa win32 win32_wasapi
36AUDIOMODS += "${@bb.utils.filter('PACKAGECONFIG', 'alsa esd jack openal portaudio sdl', d)}"
37AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'pulseaudio', 'pulse', '', d)}"
38
39EXTRA_OECONF = " \
40 --enable-shared \
41 --with-audio='${AUDIOMODS}' \
42 ${@bb.utils.contains('TUNE_FEATURES', 'neon', '--with-cpu=neon', '', d)} \
43 ${@bb.utils.contains('TUNE_FEATURES', 'altivec', '--with-cpu=altivec', '', d)} \
44"
45
46# The x86 assembler optimisations contains text relocations and there are no
47# upstream plans to fix them: http://sourceforge.net/p/mpg123/bugs/168/
48INSANE_SKIP_${PN}_append_x86 = " textrel"
49
50# Fails to build with thumb-1 (qemuarm)
51#| {standard input}: Assembler messages:
52#| {standard input}:47: Error: selected processor does not support Thumb mode `smull r5,r6,r7,r4'
53#| {standard input}:48: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r5,r5,lsr#24'
54#...
55#| make[3]: *** [equalizer.lo] Error 1
56ARM_INSTRUCTION_SET_armv4 = "arm"
57ARM_INSTRUCTION_SET_armv5 = "arm"