summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libtiff/tiff_4.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/libtiff/tiff_4.0.3.bb')
-rw-r--r--meta/recipes-multimedia/libtiff/tiff_4.0.3.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/libtiff/tiff_4.0.3.bb b/meta/recipes-multimedia/libtiff/tiff_4.0.3.bb
new file mode 100644
index 0000000000..fb9e0bf67d
--- /dev/null
+++ b/meta/recipes-multimedia/libtiff/tiff_4.0.3.bb
@@ -0,0 +1,51 @@
1SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
4HOMEPAGE = "http://www.remotesensing.org/libtiff/"
5
6SRC_URI = "ftp://ftp.remotesensing.org/pub/libtiff/tiff-${PV}.tar.gz \
7 file://libtool2.patch \
8 file://libtiff-CVE-2013-1960.patch \
9 file://libtiff-CVE-2013-4232.patch \
10 file://libtiff-CVE-2013-4243.patch \
11 file://libtiff-CVE-2013-4244.patch"
12
13SRC_URI[md5sum] = "051c1068e6a0627f461948c365290410"
14SRC_URI[sha256sum] = "ea1aebe282319537fb2d4d7805f478dd4e0e05c33d0928baba76a7c963684872"
15
16inherit autotools
17
18CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
19
20PACKAGECONFIG ?= "cxx jpeg zlib lzma \
21 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
22
23PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
24PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
25PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
26PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
27
28# Convert single-strip uncompressed images to multiple strips of specified
29# size (default: 8192) to reduce memory usage
30PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
31
32# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
33PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
34
35# Control picking up YCbCr subsample info. Disable to support files lacking
36# the tag
37PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
38
39# Support a mechanism allowing reading large strips (usually one strip files)
40# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
41PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
42
43PACKAGES =+ "tiffxx tiffxx-dbg tiffxx-dev tiffxx-staticdev tiff-utils tiff-utils-dbg"
44FILES_tiffxx = "${libdir}/libtiffxx.so.*"
45FILES_tiffxx-dev = "${libdir}/libtiffxx.so ${libdir}/libtiffxx.la"
46FILES_tiffxx-staticdev = "${libdir}/libtiffxx.a"
47FILES_tiffxx-dbg += "${libdir}/.debug/libtiffxx.so*"
48FILES_tiff-utils = "${bindir}/*"
49FILES_tiff-utils-dbg += "${bindir}/.debug/"
50
51BBCLASSEXTEND = "native"