summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libpng/libpng_1.6.40.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/libpng/libpng_1.6.40.bb')
-rw-r--r--meta/recipes-multimedia/libpng/libpng_1.6.40.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/libpng/libpng_1.6.40.bb b/meta/recipes-multimedia/libpng/libpng_1.6.40.bb
new file mode 100644
index 0000000000..0ef4b82d1c
--- /dev/null
+++ b/meta/recipes-multimedia/libpng/libpng_1.6.40.bb
@@ -0,0 +1,36 @@
1SUMMARY = "PNG image format decoding library"
2DESCRIPTION = "An open source project to develop and maintain the reference \
3library for use in applications that read, create, and manipulate PNG \
4(Portable Network Graphics) raster image files. "
5HOMEPAGE = "http://www.libpng.org/"
6SECTION = "libs"
7LICENSE = "Libpng"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=8f533bc367bfd43f556b6f782234c076"
9DEPENDS = "zlib"
10
11LIBV = "16"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/${BP}.tar.xz"
14SRC_URI[sha256sum] = "535b479b2467ff231a3ec6d92a525906fb8ef27978be4f66dbe05d3f3a01b3a1"
15
16MIRRORS += "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/ ${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/older-releases/"
17
18UPSTREAM_CHECK_URI = "http://libpng.org/pub/png/libpng.html"
19
20BINCONFIG = "${bindir}/libpng-config ${bindir}/libpng16-config"
21
22inherit autotools binconfig-disabled pkgconfig
23
24# Work around missing symbols
25ARMNEON = "${@bb.utils.contains("TUNE_FEATURES", "neon", "--enable-arm-neon=on", "--enable-arm-neon=off", d)}"
26ARMNEON:aarch64 = "--enable-hardware-optimizations=on"
27EXTRA_OECONF += "${ARMNEON}"
28
29PACKAGES =+ "${PN}-tools"
30
31FILES:${PN}-tools = "${bindir}/png-fix-itxt ${bindir}/pngfix ${bindir}/pngcp"
32
33BBCLASSEXTEND = "native nativesdk"
34
35# CVE-2019-17371 is actually a memory leak in gif2png 2.x
36CVE_CHECK_IGNORE += "CVE-2019-17371"