summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.18.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0_1.18.3.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0_1.18.3.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.18.3.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.18.3.bb
new file mode 100644
index 0000000000..7ad0248b7c
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.18.3.bb
@@ -0,0 +1,69 @@
1SUMMARY = "GStreamer 1.0 multimedia framework"
2DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
3It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
4HOMEPAGE = "http://gstreamer.freedesktop.org/"
5BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
6SECTION = "multimedia"
7LICENSE = "LGPLv2+"
8
9DEPENDS = "glib-2.0 glib-2.0-native libxml2 bison-native flex-native"
10
11inherit meson pkgconfig gettext upstream-version-is-even gobject-introspection
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
14 file://gst/gst.h;beginline=1;endline=21;md5=e059138481205ee2c6fc1c079c016d0d"
15
16S = "${WORKDIR}/gstreamer-${PV}"
17
18SRC_URI = "https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz \
19 file://0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch \
20 file://0002-Remove-unused-valgrind-detection.patch \
21 file://0003-meson-Add-option-for-installed-tests.patch \
22 "
23SRC_URI[sha256sum] = "0c2e09e18f2df69a99b5cb3bd53c597b3cc2e35cf6c98043bb86a66f3d312100"
24
25PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
26 check \
27 debug \
28 tools"
29
30PACKAGECONFIG[debug] = "-Dgst_debug=true,-Dgst_debug=false"
31PACKAGECONFIG[tracer-hooks] = "-Dtracer_hooks=true,-Dtracer_hooks=false"
32PACKAGECONFIG[check] = "-Dcheck=enabled,-Dcheck=disabled"
33PACKAGECONFIG[tests] = "-Dtests=enabled -Dinstalled-tests=true,-Dtests=disabled -Dinstalled-tests=false"
34PACKAGECONFIG[unwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind"
35PACKAGECONFIG[dw] = "-Dlibdw=enabled,-Dlibdw=disabled,elfutils"
36PACKAGECONFIG[bash-completion] = "-Dbash-completion=enabled,-Dbash-completion=disabled,bash-completion"
37PACKAGECONFIG[tools] = "-Dtools=enabled,-Dtools=disabled"
38PACKAGECONFIG[setcap] = "-Dptp-helper-permissions=capabilities,,libcap libcap-native"
39
40# TODO: put this in a gettext.bbclass patch
41def gettext_oemeson(d):
42 if d.getVar('USE_NLS') == 'no':
43 return '-Dnls=disabled'
44 # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set
45 if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'):
46 return '-Dnls=disabled'
47 return '-Dnls=enabled'
48
49EXTRA_OEMESON += " \
50 -Ddoc=disabled \
51 -Dexamples=disabled \
52 -Ddbghelp=disabled \
53 ${@gettext_oemeson(d)} \
54"
55
56GIR_MESON_ENABLE_FLAG = "enabled"
57GIR_MESON_DISABLE_FLAG = "disabled"
58
59PACKAGES += "${PN}-bash-completion"
60
61# Add the core element plugins to the main package
62FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
63FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.a ${libdir}/gstreamer-1.0/include"
64FILES_${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadir}/bash-completion/helpers/gst*"
65FILES_${PN}-dbg += "${datadir}/gdb ${datadir}/gstreamer-1.0/gdb"
66
67CVE_PRODUCT = "gstreamer"
68
69require gstreamer1.0-ptest.inc