summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.18.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.18.0.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.18.0.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.18.0.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.18.0.bb
new file mode 100644
index 0000000000..60a975bf4d
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.18.0.bb
@@ -0,0 +1,53 @@
1SUMMARY = "VA-API support to GStreamer"
2DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \
3based plugins for GStreamer and helper libraries: `vaapidecode', \
4`vaapiconvert', and `vaapisink'."
5
6REALPN = "gstreamer-vaapi"
7
8LICENSE = "LGPLv2.1+"
9LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
11SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${PV}.tar.xz"
12
13SRC_URI[md5sum] = "079a3739857e0cf4904afe92659d8a18"
14SRC_URI[sha256sum] = "c6efeb8c736f75bb1b53ab18413c60c4321300e7aee66641bcc07d59c2fe9e31"
15
16S = "${WORKDIR}/${REALPN}-${PV}"
17DEPENDS = "libva gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
18
19inherit meson pkgconfig features_check upstream-version-is-even
20
21REQUIRED_DISTRO_FEATURES ?= "opengl"
22
23EXTRA_OEMESON += " \
24 -Ddoc=disabled \
25 -Dexamples=disabled \
26 -Dtests=enabled \
27"
28
29PACKAGES =+ "${PN}-tests"
30
31# OpenGL packageconfig factored out to make it easy for distros
32# and BSP layers to pick either glx, egl, or no GL. By default,
33# try detecting X11 first, and if found (with OpenGL), use GLX,
34# otherwise try to check if EGL can be used.
35PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \
36 bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \
37 '', d), d)}"
38
39PACKAGECONFIG ??= "drm encoders \
40 ${PACKAGECONFIG_GL} \
41 ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
42
43PACKAGECONFIG[drm] = "-Dwith_drm=yes,-Dwith_drm=no,udev libdrm"
44PACKAGECONFIG[egl] = "-Dwith_egl=yes,-Dwith_egl=no,virtual/egl"
45PACKAGECONFIG[encoders] = "-Dwith_encoders=yes,-Dwith_encoders=no"
46PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/libgl"
47PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland wayland-protocols"
48PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxrandr libxrender"
49
50FILES_${PN} += "${libdir}/gstreamer-*/*.so"
51FILES_${PN}-dbg += "${libdir}/gstreamer-*/.debug"
52FILES_${PN}-dev += "${libdir}/gstreamer-*/*.a"
53FILES_${PN}-tests = "${bindir}/*"