summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.3.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.3.bb72
1 files changed, 72 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.3.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.3.bb
new file mode 100644
index 0000000000..7643e9e601
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.3.bb
@@ -0,0 +1,72 @@
1require gstreamer1.0-plugins-common.inc
2
3SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz \
4 file://0001-qt-include-ext-qt-gstqtgl.h-instead-of-gst-gl-gstglf.patch \
5 "
6
7SRC_URI[sha256sum] = "9b3b8e05d4d6073bf929fb33e2d8f74dd81ff21fa5b50c3273c78dfa2ab9c5cb"
8
9S = "${WORKDIR}/gst-plugins-good-${PV}"
10
11LICENSE = "GPLv2+ & LGPLv2.1+"
12LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
13 file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
14
15DEPENDS += "gstreamer1.0-plugins-base libcap zlib"
16RPROVIDES_${PN}-pulseaudio += "${PN}-pulse"
17RPROVIDES_${PN}-soup += "${PN}-souphttpsrc"
18
19PACKAGECONFIG ??= " \
20 ${GSTREAMER_ORC} \
21 ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio x11', d)} \
22 ${@bb.utils.contains('TUNE_FEATURES', 'm64', 'asm', '', d)} \
23 bz2 cairo flac gdk-pixbuf gudev jpeg lame libpng mpg123 soup speex taglib v4l2 \
24"
25
26X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
27X11ENABLEOPTS = "-Dximagesrc=enabled -Dximagesrc-xshm=enabled -Dximagesrc-xfixes=enabled -Dximagesrc-xdamage=enabled"
28X11DISABLEOPTS = "-Dximagesrc=disabled -Dximagesrc-xshm=disabled -Dximagesrc-xfixes=disabled -Dximagesrc-xdamage=disabled"
29
30QT5WAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
31
32PACKAGECONFIG[asm] = "-Dasm=enabled,-Dasm=disabled,nasm-native"
33PACKAGECONFIG[bz2] = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
34PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo"
35PACKAGECONFIG[dv1394] = "-Ddv1394=enabled,-Ddv1394=disabled,libiec61883 libavc1394 libraw1394"
36PACKAGECONFIG[flac] = "-Dflac=enabled,-Dflac=disabled,flac"
37PACKAGECONFIG[gdk-pixbuf] = "-Dgdk-pixbuf=enabled,-Dgdk-pixbuf=disabled,gdk-pixbuf"
38PACKAGECONFIG[gtk] = "-Dgtk3=enabled,-Dgtk3=disabled,gtk+3"
39PACKAGECONFIG[gudev] = "-Dv4l2-gudev=enabled,-Dv4l2-gudev=disabled,libgudev"
40PACKAGECONFIG[jack] = "-Djack=enabled,-Djack=disabled,jack"
41PACKAGECONFIG[jpeg] = "-Djpeg=enabled,-Djpeg=disabled,jpeg"
42PACKAGECONFIG[lame] = "-Dlame=enabled,-Dlame=disabled,lame"
43PACKAGECONFIG[libpng] = "-Dpng=enabled,-Dpng=disabled,libpng"
44PACKAGECONFIG[libv4l2] = "-Dv4l2-libv4l2=enabled,-Dv4l2-libv4l2=disabled,v4l-utils"
45PACKAGECONFIG[mpg123] = "-Dmpg123=enabled,-Dmpg123=disabled,mpg123"
46PACKAGECONFIG[pulseaudio] = "-Dpulse=enabled,-Dpulse=disabled,pulseaudio"
47PACKAGECONFIG[qt5] = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QT5WAYLANDDEPENDS}"
48PACKAGECONFIG[soup] = "-Dsoup=enabled,-Dsoup=disabled,libsoup-2.4"
49PACKAGECONFIG[speex] = "-Dspeex=enabled,-Dspeex=disabled,speex"
50PACKAGECONFIG[rpi] = "-Drpicamsrc=enabled,-Drpicamsrc=disabled,userland"
51PACKAGECONFIG[taglib] = "-Dtaglib=enabled,-Dtaglib=disabled,taglib"
52PACKAGECONFIG[v4l2] = "-Dv4l2=enabled -Dv4l2-probe=true,-Dv4l2=disabled -Dv4l2-probe=false"
53PACKAGECONFIG[vpx] = "-Dvpx=enabled,-Dvpx=disabled,libvpx"
54PACKAGECONFIG[wavpack] = "-Dwavpack=enabled,-Dwavpack=disabled,wavpack"
55PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}"
56
57EXTRA_OEMESON += " \
58 -Ddoc=disabled \
59 -Daalib=disabled \
60 -Ddirectsound=disabled \
61 -Ddv=disabled \
62 -Dlibcaca=disabled \
63 -Doss=enabled \
64 -Doss4=disabled \
65 -Dosxaudio=disabled \
66 -Dosxvideo=disabled \
67 -Dshout2=disabled \
68 -Dtwolame=disabled \
69 -Dwaveform=disabled \
70"
71
72FILES_${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"