summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.3.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.3.bb79
1 files changed, 79 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.3.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.3.bb
new file mode 100644
index 0000000000..77ccb4cc18
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.3.bb
@@ -0,0 +1,79 @@
1require gstreamer1.0-plugins.inc
2
3SRC_URI = " \
4 http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz \
5 file://0001-gstrtpmp4gpay-set-dafault-value-for-MPEG4-without-co.patch \
6 file://avoid-including-sys-poll.h-directly.patch \
7 file://ensure-valid-sentinel-for-gst_structure_get.patch \
8 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
9 "
10
11SRC_URI[md5sum] = "01904b7f000cfa6a8e96de0fa1b3ceca"
12SRC_URI[sha256sum] = "5112bce6af0be62760687ca47873c90ce4d65d3fe920a3adf8145db7b07bff5d"
13
14S = "${WORKDIR}/gst-plugins-good-${PV}"
15
16LICENSE = "GPLv2+ & LGPLv2.1+"
17LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
18 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607 \
19 file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
20
21DEPENDS += "gstreamer1.0-plugins-base libcap"
22RPROVIDES_${PN}-pulseaudio += "${PN}-pulse"
23RPROVIDES_${PN}-soup += "${PN}-souphttpsrc"
24
25inherit gettext
26
27PACKAGECONFIG ??= " \
28 ${GSTREAMER_ORC} \
29 ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio x11', d)} \
30 bz2 cairo flac gdk-pixbuf gudev jpeg lame libpng mpg123 soup speex taglib v4l2 zlib \
31"
32
33X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
34
35PACKAGECONFIG[bz2] = "--enable-bz2,--disable-bz2,bzip2"
36PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo"
37PACKAGECONFIG[dv1394] = "--enable-dv1394,--disable-dv1394,libiec61883 libavc1394 libraw1394"
38PACKAGECONFIG[flac] = "--enable-flac,--disable-flac,flac"
39PACKAGECONFIG[gdk-pixbuf] = "--enable-gdk_pixbuf,--disable-gdk_pixbuf,gdk-pixbuf"
40PACKAGECONFIG[gtk] = "--enable-gtk3,--disable-gtk3,gtk+3"
41PACKAGECONFIG[gudev] = "--with-gudev,--without-gudev,libgudev"
42PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack"
43PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
44PACKAGECONFIG[lame] = "--enable-lame,--disable-lame,lame"
45PACKAGECONFIG[libpng] = "--enable-libpng,--disable-libpng,libpng"
46PACKAGECONFIG[libv4l2] = "--with-libv4l2,--without-libv4l2,v4l-utils"
47PACKAGECONFIG[mpg123] = "--enable-mpg123,--disable-mpg123,mpg123"
48PACKAGECONFIG[pulseaudio] = "--enable-pulse,--disable-pulse,pulseaudio"
49PACKAGECONFIG[soup] = "--enable-soup,--disable-soup,libsoup-2.4"
50PACKAGECONFIG[speex] = "--enable-speex,--disable-speex,speex"
51PACKAGECONFIG[taglib] = "--enable-taglib,--disable-taglib,taglib"
52PACKAGECONFIG[v4l2] = "--enable-gst_v4l2 --enable-v4l2-probe,--disable-gst_v4l2"
53PACKAGECONFIG[vpx] = "--enable-vpx,--disable-vpx,libvpx"
54PACKAGECONFIG[wavpack] = "--enable-wavpack,--disable-wavpack,wavpack"
55PACKAGECONFIG[x11] = "--enable-x,--disable-x,${X11DEPENDS}"
56PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib"
57
58# qt5 support is disabled, because it is not present in OE core, and requires more work than
59# just adding a packageconfig (it requires access to moc, uic, rcc, and qmake paths).
60# This is better done in a separate qt5 layer (which then should add a "qt5" packageconfig
61# in a gstreamer1.0-plugins-good bbappend).
62
63EXTRA_OECONF += " \
64 --enable-oss \
65 --disable-aalib \
66 --disable-aalibtest \
67 --disable-directsound \
68 --disable-libcaca \
69 --disable-libdv \
70 --disable-oss4 \
71 --disable-osx_audio \
72 --disable-osx_video \
73 --disable-qt \
74 --disable-shout2 \
75 --disable-twolame \
76 --disable-waveform \
77"
78
79FILES_${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"