summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.8.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.8.3.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.8.3.bb34
1 files changed, 1 insertions, 33 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.8.3.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.8.3.bb
index 928d2d4313..108f4db10e 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.8.3.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.8.3.bb
@@ -18,41 +18,9 @@ SRC_URI = " \
18 file://0005-glshader-add-glBindFragDataLocation.patch \ 18 file://0005-glshader-add-glBindFragDataLocation.patch \
19 file://0006-glcolorconvert-GLES3-deprecates-texture2D-and-it-doe.patch \ 19 file://0006-glcolorconvert-GLES3-deprecates-texture2D-and-it-doe.patch \
20 file://0008-gl-implement-GstGLMemoryEGL.patch \ 20 file://0008-gl-implement-GstGLMemoryEGL.patch \
21 file://0009-glimagesink-Downrank-to-marginal.patch \
21" 22"
22SRC_URI[md5sum] = "955281a43e98c5464563fa049e0a0911" 23SRC_URI[md5sum] = "955281a43e98c5464563fa049e0a0911"
23SRC_URI[sha256sum] = "7899fcb18e6a1af2888b19c90213af018a57d741c6e72ec56b133bc73ec8509b" 24SRC_URI[sha256sum] = "7899fcb18e6a1af2888b19c90213af018a57d741c6e72ec56b133bc73ec8509b"
24 25
25S = "${WORKDIR}/gst-plugins-bad-${PV}" 26S = "${WORKDIR}/gst-plugins-bad-${PV}"
26
27# over-ride the default hls PACKAGECONFIG in gstreamer1.0-plugins-bad.inc to
28# pass an additional --with-hls-crypto=XXX option (new in 1.7.x) and switch HLS
29# AES decryption from nettle to openssl (ie a shared dependency with dtls).
30# This should move back to the common .inc once the main recipe updates to 1.8.x
31PACKAGECONFIG[hls] = "--enable-hls --with-hls-crypto=openssl,--disable-hls,openssl"
32
33# The tinyalsa plugin was added prior to the 1.7.2 release
34# https://cgit.freedesktop.org/gstreamer/gst-plugins-bad/commit/?id=c8bd74fa9a81398f57d976c478d2043f30188684
35PACKAGECONFIG[tinyalsa] = "--enable-tinyalsa,--disable-tinyalsa,tinyalsa"
36
37# The vulkan based video sink plugin was added prior to the 1.7.2 release
38# https://cgit.freedesktop.org/gstreamer/gst-plugins-bad/commit/?id=5de6dd9f40629562acf90e35e1fa58464d66617d
39PACKAGECONFIG[vulkan] = "--enable-vulkan,--disable-vulkan,libxcb"
40
41# The dependency-less netsim plugin was added prior to the 1.7.2 release
42# https://cgit.freedesktop.org/gstreamer/gst-plugins-bad/commit/?id=e3f9e854f08e82bfab11182c5a2aa6f9a0c73cd5
43EXTRA_OECONF += " \
44 --enable-netsim \
45"
46
47# In 1.6.2, the "--enable-hls" configure option generated an installable package
48# called "gstreamer1.0-plugins-bad-fragmented". In 1.7.1 that HLS plugin package
49# has become "gstreamer1.0-plugins-bad-hls". See:
50# http://cgit.freedesktop.org/gstreamer/gst-plugins-bad/commit/?id=efe62292a3d045126654d93239fdf4cc8e48ae08
51
52PACKAGESPLITFUNCS_append = " handle_hls_rename "
53
54python handle_hls_rename () {
55 d.setVar('RPROVIDES_gstreamer1.0-plugins-bad-hls', 'gstreamer1.0-plugins-bad-fragmented')
56 d.setVar('RREPLACES_gstreamer1.0-plugins-bad-hls', 'gstreamer1.0-plugins-bad-fragmented')
57 d.setVar('RCONFLICTS_gstreamer1.0-plugins-bad-hls', 'gstreamer1.0-plugins-bad-fragmented')
58}