summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.8.2.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.8.2.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.8.2.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.8.2.bb
new file mode 100644
index 0000000000..c7d67f854c
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.8.2.bb
@@ -0,0 +1,52 @@
1include gstreamer1.0-plugins-bad.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=73a5855a8119deb017f5f13cf327095d \
4 file://COPYING.LIB;md5=21682e4e8fea52413fd26c60acb907e5 \
5 file://gst/tta/crc32.h;beginline=12;endline=29;md5=27db269c575d1e5317fffca2d33b3b50 \
6 file://gst/tta/filters.h;beginline=12;endline=29;md5=8a08270656f2f8ad7bb3655b83138e5a"
7
8SRC_URI = " \
9 http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-${PV}.tar.xz \
10 file://configure-allow-to-disable-libssh2.patch \
11 file://fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch \
12 file://avoid-including-sys-poll.h-directly.patch \
13 file://ensure-valid-sentinels-for-gst_structure_get-etc.patch \
14 file://0001-gstreamer-gl.pc.in-don-t-append-GL_CFLAGS-to-CFLAGS.patch \
15"
16SRC_URI[md5sum] = "83abc2e70684e7b195f18ca2992ef6e8"
17SRC_URI[sha256sum] = "d7995317530c8773ec088f94d9320909d41da61996b801ebacce9a56af493f97"
18
19S = "${WORKDIR}/gst-plugins-bad-${PV}"
20
21# over-ride the default hls PACKAGECONFIG in gstreamer1.0-plugins-bad.inc to
22# pass an additional --with-hls-crypto=XXX option (new in 1.7.x) and switch HLS
23# AES decryption from nettle to openssl (ie a shared dependency with dtls).
24# This should move back to the common .inc once the main recipe updates to 1.8.x
25PACKAGECONFIG[hls] = "--enable-hls --with-hls-crypto=openssl,--disable-hls,openssl"
26
27# The tinyalsa plugin was added prior to the 1.7.2 release
28# https://cgit.freedesktop.org/gstreamer/gst-plugins-bad/commit/?id=c8bd74fa9a81398f57d976c478d2043f30188684
29PACKAGECONFIG[tinyalsa] = "--enable-tinyalsa,--disable-tinyalsa,tinyalsa"
30
31# The vulkan based video sink plugin was added prior to the 1.7.2 release
32# https://cgit.freedesktop.org/gstreamer/gst-plugins-bad/commit/?id=5de6dd9f40629562acf90e35e1fa58464d66617d
33PACKAGECONFIG[vulkan] = "--enable-vulkan,--disable-vulkan,libxcb"
34
35# The dependency-less netsim plugin was added prior to the 1.7.2 release
36# https://cgit.freedesktop.org/gstreamer/gst-plugins-bad/commit/?id=e3f9e854f08e82bfab11182c5a2aa6f9a0c73cd5
37EXTRA_OECONF += " \
38 --enable-netsim \
39"
40
41# In 1.6.2, the "--enable-hls" configure option generated an installable package
42# called "gstreamer1.0-plugins-bad-fragmented". In 1.7.1 that HLS plugin package
43# has become "gstreamer1.0-plugins-bad-hls". See:
44# http://cgit.freedesktop.org/gstreamer/gst-plugins-bad/commit/?id=efe62292a3d045126654d93239fdf4cc8e48ae08
45
46PACKAGESPLITFUNCS_append = " handle_hls_rename "
47
48python handle_hls_rename () {
49 d.setVar('RPROVIDES_gstreamer1.0-plugins-bad-hls', 'gstreamer1.0-plugins-bad-fragmented')
50 d.setVar('RREPLACES_gstreamer1.0-plugins-bad-hls', 'gstreamer1.0-plugins-bad-fragmented')
51 d.setVar('RCONFLICTS_gstreamer1.0-plugins-bad-hls', 'gstreamer1.0-plugins-bad-fragmented')
52}