summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.3.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.3.bb147
1 files changed, 147 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.3.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.3.bb
new file mode 100644
index 0000000000..bbb7427b07
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.3.bb
@@ -0,0 +1,147 @@
1require gstreamer1.0-plugins-common.inc
2
3SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-${PV}.tar.xz \
4 file://0001-fix-maybe-uninitialized-warnings-when-compiling-with.patch \
5 file://0002-avoid-including-sys-poll.h-directly.patch \
6 file://0003-ensure-valid-sentinals-for-gst_structure_get-etc.patch \
7 file://0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch \
8 file://0005-msdk-fix-includedir-path.patch \
9 "
10SRC_URI[sha256sum] = "b7e34b6b86272588fbd8b314dadfa6ceff895198cfb59e2950378e9e31ff22e0"
11
12S = "${WORKDIR}/gst-plugins-bad-${PV}"
13
14LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+"
15LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
16
17DEPENDS += "gstreamer1.0-plugins-base"
18
19inherit gobject-introspection
20
21PACKAGECONFIG ??= " \
22 ${GSTREAMER_ORC} \
23 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
24 ${@bb.utils.filter('DISTRO_FEATURES', 'directfb vulkan', d)} \
25 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \
26 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)} \
27 bz2 closedcaption curl dash dtls hls rsvg sbc smoothstreaming sndfile \
28 ttml uvch264 webp \
29"
30
31PACKAGECONFIG[aom] = "-Daom=enabled,-Daom=disabled,aom"
32PACKAGECONFIG[assrender] = "-Dassrender=enabled,-Dassrender=disabled,libass"
33PACKAGECONFIG[bluez] = "-Dbluez=enabled,-Dbluez=disabled,bluez5"
34PACKAGECONFIG[bz2] = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
35PACKAGECONFIG[closedcaption] = "-Dclosedcaption=enabled,-Dclosedcaption=disabled,pango cairo"
36PACKAGECONFIG[curl] = "-Dcurl=enabled,-Dcurl=disabled,curl"
37PACKAGECONFIG[dash] = "-Ddash=enabled,-Ddash=disabled,libxml2"
38PACKAGECONFIG[dc1394] = "-Ddc1394=enabled,-Ddc1394=disabled,libdc1394"
39PACKAGECONFIG[directfb] = "-Ddirectfb=enabled,-Ddirectfb=disabled,directfb"
40PACKAGECONFIG[dtls] = "-Ddtls=enabled,-Ddtls=disabled,openssl"
41PACKAGECONFIG[faac] = "-Dfaac=enabled,-Dfaac=disabled,faac"
42PACKAGECONFIG[faad] = "-Dfaad=enabled,-Dfaad=disabled,faad2"
43PACKAGECONFIG[fluidsynth] = "-Dfluidsynth=enabled,-Dfluidsynth=disabled,fluidsynth"
44PACKAGECONFIG[hls] = "-Dhls=enabled -Dhls-crypto=nettle,-Dhls=disabled,nettle"
45# the gl packageconfig enables OpenGL elements that haven't been ported
46# to -base yet. They depend on the gstgl library in -base, so we do
47# not add GL dependencies here, since these are taken care of in -base.
48PACKAGECONFIG[gl] = "-Dgl=enabled,-Dgl=disabled,"
49PACKAGECONFIG[kms] = "-Dkms=enabled,-Dkms=disabled,libdrm"
50PACKAGECONFIG[libde265] = "-Dlibde265=enabled,-Dlibde265=disabled,libde265"
51PACKAGECONFIG[libmms] = "-Dlibmms=enabled,-Dlibmms=disabled,libmms"
52PACKAGECONFIG[libssh2] = "-Dcurl-ssh2=enabled,-Dcurl-ssh2=disabled,libssh2"
53PACKAGECONFIG[lcms2] = "-Dcolormanagement=enabled,-Dcolormanagement=disabled,lcms"
54PACKAGECONFIG[modplug] = "-Dmodplug=enabled,-Dmodplug=disabled,libmodplug"
55PACKAGECONFIG[msdk] = "-Dmsdk=enabled,-Dmsdk=disabled,intel-mediasdk"
56PACKAGECONFIG[neon] = "-Dneon=enabled,-Dneon=disabled,neon"
57PACKAGECONFIG[openal] = "-Dopenal=enabled,-Dopenal=disabled,openal-soft"
58PACKAGECONFIG[opencv] = "-Dopencv=enabled,-Dopencv=disabled,opencv"
59PACKAGECONFIG[openh264] = "-Dopenh264=enabled,-Dopenh264=disabled,openh264"
60PACKAGECONFIG[openjpeg] = "-Dopenjpeg=enabled,-Dopenjpeg=disabled,openjpeg"
61PACKAGECONFIG[openmpt] = "-Dopenmpt=enabled,-Dopenmpt=disabled,libopenmpt"
62# the opus encoder/decoder elements are now in the -base package,
63# but the opus parser remains in -bad
64PACKAGECONFIG[opusparse] = "-Dopus=enabled,-Dopus=disabled,libopus"
65PACKAGECONFIG[resindvd] = "-Dresindvd=enabled,-Dresindvd=disabled,libdvdread libdvdnav"
66PACKAGECONFIG[rsvg] = "-Drsvg=enabled,-Drsvg=disabled,librsvg"
67PACKAGECONFIG[rtmp] = "-Drtmp=enabled,-Drtmp=disabled,rtmpdump"
68PACKAGECONFIG[sbc] = "-Dsbc=enabled,-Dsbc=disabled,sbc"
69PACKAGECONFIG[sctp] = "-Dsctp=enabled,-Dsctp=disabled"
70PACKAGECONFIG[smoothstreaming] = "-Dsmoothstreaming=enabled,-Dsmoothstreaming=disabled,libxml2"
71PACKAGECONFIG[sndfile] = "-Dsndfile=enabled,-Dsndfile=disabled,libsndfile1"
72PACKAGECONFIG[srt] = "-Dsrt=enabled,-Dsrt=disabled,srt"
73PACKAGECONFIG[srtp] = "-Dsrtp=enabled,-Dsrtp=disabled,libsrtp"
74PACKAGECONFIG[tinyalsa] = "-Dtinyalsa=enabled,-Dtinyalsa=disabled,tinyalsa"
75PACKAGECONFIG[ttml] = "-Dttml=enabled,-Dttml=disabled,libxml2 pango cairo"
76PACKAGECONFIG[uvch264] = "-Duvch264=enabled,-Duvch264=disabled,libusb1 libgudev"
77PACKAGECONFIG[v4l2codecs] = "-Dv4l2codecs=enabled,-Dv4l2codecs=disabled,libgudev"
78PACKAGECONFIG[va] = "-Dva=enabled,-Dva=disabled,libva"
79PACKAGECONFIG[voaacenc] = "-Dvoaacenc=enabled,-Dvoaacenc=disabled,vo-aacenc"
80PACKAGECONFIG[voamrwbenc] = "-Dvoamrwbenc=enabled,-Dvoamrwbenc=disabled,vo-amrwbenc"
81PACKAGECONFIG[vulkan] = "-Dvulkan=enabled,-Dvulkan=disabled,vulkan-loader shaderc-native"
82PACKAGECONFIG[wayland] = "-Dwayland=enabled,-Dwayland=disabled,wayland-native wayland wayland-protocols libdrm"
83PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,libwebp"
84PACKAGECONFIG[webrtc] = "-Dwebrtc=enabled,-Dwebrtc=disabled,libnice"
85PACKAGECONFIG[webrtcdsp] = "-Dwebrtcdsp=enabled,-Dwebrtcdsp=disabled,webrtc-audio-processing"
86PACKAGECONFIG[zbar] = "-Dzbar=enabled,-Dzbar=disabled,zbar"
87PACKAGECONFIG[x265] = "-Dx265=enabled,-Dx265=disabled,x265"
88
89EXTRA_OEMESON += " \
90 -Ddoc=disabled \
91 -Ddecklink=enabled \
92 -Ddvb=enabled \
93 -Dfbdev=enabled \
94 -Dipcpipeline=enabled \
95 -Dshm=enabled \
96 -Dtranscode=enabled \
97 -Dandroidmedia=disabled \
98 -Dapplemedia=disabled \
99 -Davtp=disabled \
100 -Dbs2b=disabled \
101 -Dchromaprint=disabled \
102 -Dd3dvideosink=disabled \
103 -Dd3d11=disabled \
104 -Ddirectsound=disabled \
105 -Ddts=disabled \
106 -Dfdkaac=disabled \
107 -Dflite=disabled \
108 -Dgme=disabled \
109 -Dgsm=disabled \
110 -Diqa=disabled \
111 -Dkate=disabled \
112 -Dladspa=disabled \
113 -Dlv2=disabled \
114 -Dmagicleap=disabled \
115 -Dmediafoundation=disabled \
116 -Dmicrodns=disabled \
117 -Dmpeg2enc=disabled \
118 -Dmplex=disabled \
119 -Dmusepack=disabled \
120 -Dnvcodec=disabled \
121 -Dofa=disabled \
122 -Dopenexr=disabled \
123 -Dopenni2=disabled \
124 -Dopensles=disabled \
125 -Dsoundtouch=disabled \
126 -Dspandsp=disabled \
127 -Dsvthevcenc=disabled \
128 -Dteletext=disabled \
129 -Dwasapi=disabled \
130 -Dwasapi2=disabled \
131 -Dwildmidi=disabled \
132 -Dwinks=disabled \
133 -Dwinscreencap=disabled \
134 -Dwpe=disabled \
135 -Dzxing=disabled \
136"
137
138export OPENCV_PREFIX = "${STAGING_DIR_TARGET}${prefix}"
139
140ARM_INSTRUCTION_SET_armv4 = "arm"
141ARM_INSTRUCTION_SET_armv5 = "arm"
142
143FILES_${PN}-freeverb += "${datadir}/gstreamer-1.0/presets/GstFreeverb.prs"
144FILES_${PN}-opencv += "${datadir}/gst-plugins-bad/1.0/opencv*"
145FILES_${PN}-transcode += "${datadir}/gstreamer-1.0/encoding-profiles"
146FILES_${PN}-voamrwbenc += "${datadir}/gstreamer-1.0/presets/GstVoAmrwbEnc.prs"
147