summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.2.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.2.bb153
1 files changed, 153 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.2.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.2.bb
new file mode 100644
index 0000000000..f70437ccd3
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.2.bb
@@ -0,0 +1,153 @@
1require gstreamer1.0-plugins-common.inc
2
3SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-${PV}.tar.xz \
4 file://0001-fix-maybe-uninitialized-warnings-when-compiling-with.patch \
5 file://0002-avoid-including-sys-poll.h-directly.patch \
6 file://0003-ensure-valid-sentinals-for-gst_structure_get-etc.patch \
7 file://0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch \
8 "
9SRC_URI[sha256sum] = "8ad5822f1118fe46a19af54422b74e3a16d79a6800dcb173b49e199a496b341a"
10
11S = "${WORKDIR}/gst-plugins-bad-${PV}"
12
13LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+"
14LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
15
16DEPENDS += "gstreamer1.0-plugins-base"
17
18inherit gobject-introspection
19
20PACKAGECONFIG ??= " \
21 ${GSTREAMER_ORC} \
22 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
23 ${@bb.utils.filter('DISTRO_FEATURES', 'directfb vulkan', d)} \
24 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \
25 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)} \
26 bz2 closedcaption curl dash dtls hls rsvg sbc smoothstreaming sndfile \
27 ttml uvch264 webp \
28"
29
30PACKAGECONFIG[assrender] = "-Dassrender=enabled,-Dassrender=disabled,libass"
31PACKAGECONFIG[bluez] = "-Dbluez=enabled,-Dbluez=disabled,bluez5"
32PACKAGECONFIG[bz2] = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
33PACKAGECONFIG[closedcaption] = "-Dclosedcaption=enabled,-Dclosedcaption=disabled,pango cairo"
34PACKAGECONFIG[curl] = "-Dcurl=enabled,-Dcurl=disabled,curl"
35PACKAGECONFIG[dash] = "-Ddash=enabled,-Ddash=disabled,libxml2"
36PACKAGECONFIG[dc1394] = "-Ddc1394=enabled,-Ddc1394=disabled,libdc1394"
37PACKAGECONFIG[directfb] = "-Ddirectfb=enabled,-Ddirectfb=disabled,directfb"
38PACKAGECONFIG[dtls] = "-Ddtls=enabled,-Ddtls=disabled,openssl"
39PACKAGECONFIG[faac] = "-Dfaac=enabled,-Dfaac=disabled,faac"
40PACKAGECONFIG[faad] = "-Dfaad=enabled,-Dfaad=disabled,faad2"
41PACKAGECONFIG[fluidsynth] = "-Dfluidsynth=enabled,-Dfluidsynth=disabled,fluidsynth"
42PACKAGECONFIG[hls] = "-Dhls=enabled -Dhls-crypto=nettle,-Dhls=disabled,nettle"
43# the gl packageconfig enables OpenGL elements that haven't been ported
44# to -base yet. They depend on the gstgl library in -base, so we do
45# not add GL dependencies here, since these are taken care of in -base.
46PACKAGECONFIG[gl] = "-Dgl=enabled,-Dgl=disabled,"
47PACKAGECONFIG[kms] = "-Dkms=enabled,-Dkms=disabled,libdrm"
48PACKAGECONFIG[libde265] = "-Dlibde265=enabled,-Dlibde265=disabled,libde265"
49PACKAGECONFIG[libmms] = "-Dlibmms=enabled,-Dlibmms=disabled,libmms"
50PACKAGECONFIG[libssh2] = "-Dcurl-ssh2=enabled,-Dcurl-ssh2=disabled,libssh2"
51PACKAGECONFIG[lcms2] = "-Dcolormanagement=enabled,-Dcolormanagement=disabled,lcms"
52PACKAGECONFIG[modplug] = "-Dmodplug=enabled,-Dmodplug=disabled,libmodplug"
53PACKAGECONFIG[msdk] = "-Dmsdk=enabled,-Dmsdk=disabled,intel-mediasdk"
54PACKAGECONFIG[neon] = "-Dneon=enabled,-Dneon=disabled,neon"
55PACKAGECONFIG[openal] = "-Dopenal=enabled,-Dopenal=disabled,openal-soft"
56PACKAGECONFIG[opencv] = "-Dopencv=enabled,-Dopencv=disabled,opencv"
57PACKAGECONFIG[openh264] = "-Dopenh264=enabled,-Dopenh264=disabled,openh264"
58PACKAGECONFIG[openjpeg] = "-Dopenjpeg=enabled,-Dopenjpeg=disabled,openjpeg"
59PACKAGECONFIG[openmpt] = "-Dopenmpt=enabled,-Dopenmpt=disabled,libopenmpt"
60# the opus encoder/decoder elements are now in the -base package,
61# but the opus parser remains in -bad
62PACKAGECONFIG[opusparse] = "-Dopus=enabled,-Dopus=disabled,libopus"
63PACKAGECONFIG[resindvd] = "-Dresindvd=enabled,-Dresindvd=disabled,libdvdread libdvdnav"
64PACKAGECONFIG[rsvg] = "-Drsvg=enabled,-Drsvg=disabled,librsvg"
65PACKAGECONFIG[rtmp] = "-Drtmp=enabled,-Drtmp=disabled,rtmpdump"
66PACKAGECONFIG[sbc] = "-Dsbc=enabled,-Dsbc=disabled,sbc"
67PACKAGECONFIG[sctp] = "-Dsctp=enabled,-Dsctp=disabled,usrsctp"
68PACKAGECONFIG[smoothstreaming] = "-Dsmoothstreaming=enabled,-Dsmoothstreaming=disabled,libxml2"
69PACKAGECONFIG[sndfile] = "-Dsndfile=enabled,-Dsndfile=disabled,libsndfile1"
70PACKAGECONFIG[srt] = "-Dsrt=enabled,-Dsrt=disabled,srt"
71PACKAGECONFIG[srtp] = "-Dsrtp=enabled,-Dsrtp=disabled,libsrtp"
72PACKAGECONFIG[tinyalsa] = "-Dtinyalsa=enabled,-Dtinyalsa=disabled,tinyalsa"
73PACKAGECONFIG[ttml] = "-Dttml=enabled,-Dttml=disabled,libxml2 pango cairo"
74PACKAGECONFIG[uvch264] = "-Duvch264=enabled,-Duvch264=disabled,libusb1 libgudev"
75PACKAGECONFIG[va] = "-Dva=enabled,-Dva=disabled,libva"
76PACKAGECONFIG[voaacenc] = "-Dvoaacenc=enabled,-Dvoaacenc=disabled,vo-aacenc"
77PACKAGECONFIG[voamrwbenc] = "-Dvoamrwbenc=enabled,-Dvoamrwbenc=disabled,vo-amrwbenc"
78PACKAGECONFIG[vulkan] = "-Dvulkan=enabled,-Dvulkan=disabled,vulkan-loader shaderc-native"
79PACKAGECONFIG[wayland] = "-Dwayland=enabled,-Dwayland=disabled,wayland-native wayland wayland-protocols libdrm"
80PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,libwebp"
81PACKAGECONFIG[webrtc] = "-Dwebrtc=enabled,-Dwebrtc=disabled,libnice"
82PACKAGECONFIG[webrtcdsp] = "-Dwebrtcdsp=enabled,-Dwebrtcdsp=disabled,webrtc-audio-processing"
83PACKAGECONFIG[zbar] = "-Dzbar=enabled,-Dzbar=disabled,zbar"
84PACKAGECONFIG[v4l2codecs] = "-D-Dv4l2codecs=enabled,-Dv4l2codecs=disabled,libgudev"
85
86# these plugins currently have no corresponding library in OE-core or meta-openembedded:
87# aom androidmedia applemedia bs2b chromaprint d3dvideosink
88# directsound dts fdkaac gme gsm iq kate ladspa lv2 mpeg2enc
89# mplex musepack nvdec nvenc ofa openexr openni2 opensles
90# soundtouch spandsp teletext wasapi wildmidi winks
91# winscreencap wpe x265
92
93EXTRA_OEMESON += " \
94 -Ddoc=disabled \
95 -Ddecklink=enabled \
96 -Ddvb=enabled \
97 -Dfbdev=enabled \
98 -Dipcpipeline=enabled \
99 -Dnetsim=enabled \
100 -Dshm=enabled \
101 -Daom=disabled \
102 -Dandroidmedia=disabled \
103 -Dapplemedia=disabled \
104 -Davtp=disabled \
105 -Dbs2b=disabled \
106 -Dchromaprint=disabled \
107 -Dd3dvideosink=disabled \
108 -Dd3d11=disabled \
109 -Ddirectsound=disabled \
110 -Ddts=disabled \
111 -Dfdkaac=disabled \
112 -Dflite=disabled \
113 -Dgme=disabled \
114 -Dgsm=disabled \
115 -Diqa=disabled \
116 -Dkate=disabled \
117 -Dladspa=disabled \
118 -Dlv2=disabled \
119 -Dmagicleap=disabled \
120 -Dmediafoundation=disabled \
121 -Dmicrodns=disabled \
122 -Dmpeg2enc=disabled \
123 -Dmplex=disabled \
124 -Dmusepack=disabled \
125 -Dnvcodec=disabled \
126 -Dofa=disabled \
127 -Dopenexr=disabled \
128 -Dopenni2=disabled \
129 -Dopensles=disabled \
130 -Dsoundtouch=disabled \
131 -Dspandsp=disabled \
132 -Dsvthevcenc=disabled \
133 -Dteletext=disabled \
134 -Dwasapi=disabled \
135 -Dwasapi2=disabled \
136 -Dwildmidi=disabled \
137 -Dwinks=disabled \
138 -Dwinscreencap=disabled \
139 -Dwpe=disabled \
140 -Dx265=disabled \
141 -Dzxing=disabled \
142"
143
144export OPENCV_PREFIX = "${STAGING_DIR_TARGET}${prefix}"
145
146ARM_INSTRUCTION_SET_armv4 = "arm"
147ARM_INSTRUCTION_SET_armv5 = "arm"
148
149FILES_${PN}-freeverb += "${datadir}/gstreamer-1.0/presets/GstFreeverb.prs"
150FILES_${PN}-opencv += "${datadir}/gst-plugins-bad/1.0/opencv*"
151FILES_${PN}-transcode += "${datadir}/gstreamer-1.0/encoding-profiles"
152FILES_${PN}-voamrwbenc += "${datadir}/gstreamer-1.0/presets/GstVoAmrwbEnc.prs"
153