summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gst-examples_1.18.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gst-examples_1.18.3.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-examples_1.18.3.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-examples_1.18.3.bb b/meta/recipes-multimedia/gstreamer/gst-examples_1.18.3.bb
new file mode 100644
index 0000000000..35a8928f51
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gst-examples_1.18.3.bb
@@ -0,0 +1,32 @@
1SUMMARY = "GStreamer examples (including gtk-play, gst-play)"
2LICENSE = "LGPL-2.0+"
3LIC_FILES_CHKSUM = "file://playback/player/gtk/gtk-play.c;beginline=1;endline=20;md5=f8c72dae3d36823ec716a9ebcae593b9"
4
5DEPENDS = "glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad gtk+3 libsoup-2.4 json-glib glib-2.0-native"
6
7SRC_URI = "git://gitlab.freedesktop.org/gstreamer/gst-examples.git;protocol=https;branch=1.18 \
8 file://0001-Make-player-examples-installable.patch \
9 file://gst-player.desktop \
10 "
11
12SRCREV = "06599904baa5d0e47b5cb9501372156567760f8e"
13
14S = "${WORKDIR}/git"
15
16inherit meson pkgconfig features_check
17
18UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)"
19
20ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
21
22do_install_append() {
23 install -m 0644 -D ${WORKDIR}/gst-player.desktop ${D}${datadir}/applications/gst-player.desktop
24}
25
26RDEPENDS_${PN} = "gstreamer1.0-plugins-base-playback"
27RRECOMMENDS_${PN} = "gstreamer1.0-plugins-base-meta \
28 gstreamer1.0-plugins-good-meta \
29 gstreamer1.0-plugins-bad-meta \
30 ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-libav", "", d)} \
31 ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-plugins-ugly-meta", "", d)}"
32RPROVIDES_${PN} += "gst-player gst-player-bin"