summaryrefslogtreecommitdiffstats
path: root/meta/recipes-lsb4/perl/libfile-checktree-perl_4.41.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-lsb4/perl/libfile-checktree-perl_4.41.bb')
-rw-r--r--meta/recipes-lsb4/perl/libfile-checktree-perl_4.41.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-lsb4/perl/libfile-checktree-perl_4.41.bb b/meta/recipes-lsb4/perl/libfile-checktree-perl_4.41.bb
new file mode 100644
index 0000000000..ce37c72ca8
--- /dev/null
+++ b/meta/recipes-lsb4/perl/libfile-checktree-perl_4.41.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Perl module that run many filetest checks on a tree"
2DESCRIPTION = "The validate() routine takes a single multiline string consisting \
3of directives, each containing a filename plus a file test to try on it. (The file \
4test may also be a "cd", causing subsequent relative filenames to be interpreted \
5relative to that directory.) After the file test you may put || die to make it a \
6fatal error if the file test fails. The default is || warn. The file test may \
7optionally have a "!' prepended to test for the opposite condition. If you do a \
8cd and then list some relative filenames, you may want to indent them slightly for \
9readability. If you supply your own die() or warn() message, you can use $file to \
10interpolate the filename. \
11\
12Filetests may be bunched: "-rwx" tests for all of -r, -w, and -x. Only the first failed \
13test of the bunch will produce a warning. \
14\
15The routine returns the number of warnings issued."
16
17HOMEPAGE = "http://search.cpan.org/~flora/File-CheckTree/"
18SECTION = "libs"
19LICENSE = "Artistic-1.0 | GPL-1.0+"
20
21LIC_FILES_CHKSUM = "file://LICENSE;md5=c6fcacc5df80e037060300a7f4b93bf9"
22
23SRC_URI = "http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/File-CheckTree-${PV}.tar.gz"
24
25SRC_URI[md5sum] = "519c82aa7e5b7f752b4da14a6c8ad740"
26SRC_URI[sha256sum] = "fc99ab6bb5af4664832715974b5a19e328071dc9202ab72e5d5a594ebd46a729"
27
28S = "${WORKDIR}/File-CheckTree-${PV}"
29
30inherit cpan
31
32BBCLASSEXTEND = "native"