summaryrefslogtreecommitdiffstats
path: root/meta/recipes-lsb4/perl/libclass-isa-perl_0.36.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-lsb4/perl/libclass-isa-perl_0.36.bb')
-rw-r--r--meta/recipes-lsb4/perl/libclass-isa-perl_0.36.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-lsb4/perl/libclass-isa-perl_0.36.bb b/meta/recipes-lsb4/perl/libclass-isa-perl_0.36.bb
new file mode 100644
index 0000000000..f93841dc7f
--- /dev/null
+++ b/meta/recipes-lsb4/perl/libclass-isa-perl_0.36.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Perl module for reporting the search path for a class's ISA tree"
2DESCRIPTION = "Suppose you have a class (like Food::Fish::Fishstick) that is derived, \
3via its @ISA, from one or more superclasses (as Food::Fish::Fishstick is from Food::Fish,\
4Life::Fungus, and Chemicals), and some of those superclasses may themselves each be\
5derived, via its @ISA, from one or more superclasses (as above).\
6\
7When, then, you call a method in that class ($fishstick->calories), Perl first searches\
8there for that method, but if it's not there, it goes searching in its superclasses, and\
9so on, in a depth-first (or maybe "height-first" is the word) search. In the above example,\
10it'd first look in Food::Fish, then Food, then Matter, then Life::Fungus, then Life, then\
11Chemicals.\
12\
13This library, Class::ISA, provides functions that return that list -- the list\
14(in order) of names of classes Perl would search to find a method, with no duplicates."
15
16HOMEPAGE = "http://search.cpan.org/dist/Class-ISA/"
17SECTION = "libs"
18LICENSE = "Artistic-1.0 | GPL-1.0+"
19
20LIC_FILES_CHKSUM = "file://README;beginline=107;endline=111;md5=6a5c6842a63cfe4dab1f66e2350e4d25"
21
22SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SM/SMUELLER/Class-ISA-${PV}.tar.gz"
23
24SRC_URI[md5sum] = "3a2ad203c8dc87d6c9de16215d00af47"
25SRC_URI[sha256sum] = "8816f34e9a38e849a10df756030dccf9fe061a196c11ac3faafd7113c929b964"
26
27S = "${WORKDIR}/Class-ISA-${PV}"
28
29inherit cpan
30
31BBCLASSEXTEND = "native"