summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/systemtap/systemtap_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/systemtap/systemtap_git.bb')
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb26
1 files changed, 13 insertions, 13 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index c4a6eef59a..8161a448c8 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -33,46 +33,46 @@ inherit ${@bb.utils.contains('PACKAGECONFIG', 'python3-probes', 'distutils3-base
33 33
34# exporter comes with python3-probes 34# exporter comes with python3-probes
35PACKAGES =+ "${PN}-exporter" 35PACKAGES =+ "${PN}-exporter"
36FILES_${PN}-exporter = "${sysconfdir}/stap-exporter/* \ 36FILES:${PN}-exporter = "${sysconfdir}/stap-exporter/* \
37 ${sysconfdir}/sysconfig/stap-exporter \ 37 ${sysconfdir}/sysconfig/stap-exporter \
38 ${systemd_unitdir}/system/stap-exporter.service \ 38 ${systemd_unitdir}/system/stap-exporter.service \
39 ${sbindir}/stap-exporter" 39 ${sbindir}/stap-exporter"
40RDEPENDS_${PN}-exporter = "${PN} python3-core python3-netclient" 40RDEPENDS:${PN}-exporter = "${PN} python3-core python3-netclient"
41SYSTEMD_SERVICE_${PN}-exporter = "stap-exporter.service" 41SYSTEMD_SERVICE:${PN}-exporter = "stap-exporter.service"
42 42
43PACKAGES =+ "${PN}-runtime" 43PACKAGES =+ "${PN}-runtime"
44FILES_${PN}-runtime = "\ 44FILES:${PN}-runtime = "\
45 ${bindir}/staprun \ 45 ${bindir}/staprun \
46 ${bindir}/stap-merge \ 46 ${bindir}/stap-merge \
47 ${bindir}/stapsh \ 47 ${bindir}/stapsh \
48 ${libexecdir}/${BPN}/stapio \ 48 ${libexecdir}/${BPN}/stapio \
49" 49"
50RDEPENDS_${PN}_class-target += "${PN}-runtime" 50RDEPENDS:${PN}:class-target += "${PN}-runtime"
51 51
52PACKAGES =+ "${PN}-examples" 52PACKAGES =+ "${PN}-examples"
53FILES_${PN}-examples = "${datadir}/${BPN}/examples/" 53FILES:${PN}-examples = "${datadir}/${BPN}/examples/"
54RDEPENDS_${PN}-examples += "${PN}" 54RDEPENDS:${PN}-examples += "${PN}"
55 55
56# don't complain that some examples involve bash, perl, php... 56# don't complain that some examples involve bash, perl, php...
57INSANE_SKIP_${PN}-examples += "file-rdeps" 57INSANE_SKIP:${PN}-examples += "file-rdeps"
58 58
59PACKAGES =+ "${PN}-python" 59PACKAGES =+ "${PN}-python"
60FILES_${PN}-python += "\ 60FILES:${PN}-python += "\
61 ${bindir}/dtrace \ 61 ${bindir}/dtrace \
62 ${libdir}/python*/ \ 62 ${libdir}/python*/ \
63 ${libexecdir}/${BPN}/python/ \ 63 ${libexecdir}/${BPN}/python/ \
64" 64"
65# python material requires sdt headers 65# python material requires sdt headers
66RDEPENDS_${PN}-python += "${PN}-dev python3-core" 66RDEPENDS:${PN}-python += "${PN}-dev python3-core"
67INSANE_SKIP_${PN}-python += "dev-deps" 67INSANE_SKIP:${PN}-python += "dev-deps"
68 68
69do_configure_prepend () { 69do_configure:prepend () {
70 # Improve reproducibility for c++ object files 70 # Improve reproducibility for c++ object files
71 reltivepath="${@os.path.relpath(d.getVar('STAGING_INCDIR'), d.getVar('S'))}" 71 reltivepath="${@os.path.relpath(d.getVar('STAGING_INCDIR'), d.getVar('S'))}"
72 sed -i "s:@RELATIVE_STAGING_INCDIR@:$reltivepath:g" ${S}/stringtable.h 72 sed -i "s:@RELATIVE_STAGING_INCDIR@:$reltivepath:g" ${S}/stringtable.h
73} 73}
74 74
75do_install_append () { 75do_install:append () {
76 if [ ! -f ${D}${bindir}/stap ]; then 76 if [ ! -f ${D}${bindir}/stap ]; then
77 # translator disabled case, need to leave only minimal runtime 77 # translator disabled case, need to leave only minimal runtime
78 rm -rf ${D}${datadir}/${PN} 78 rm -rf ${D}${datadir}/${PN}