summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/systemtap/systemtap_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/systemtap/systemtap_git.bb')
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb41
1 files changed, 24 insertions, 17 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index c4a6eef59a..68f5c76428 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -6,7 +6,10 @@ HOMEPAGE = "https://sourceware.org/systemtap/"
6 6
7require systemtap_git.inc 7require systemtap_git.inc
8 8
9SRC_URI += "file://0001-improve-reproducibility-for-c-compiling.patch" 9SRC_URI += " \
10 file://0001-improve-reproducibility-for-c-compiling.patch \
11 file://0001-staprun-address-ncurses-6.3-failures.patch \
12 "
10 13
11DEPENDS = "elfutils" 14DEPENDS = "elfutils"
12 15
@@ -21,58 +24,62 @@ STAP_DOCS ?= "--disable-docs --disable-publican --disable-refdocs"
21 24
22EXTRA_OECONF += "${STAP_DOCS} " 25EXTRA_OECONF += "${STAP_DOCS} "
23 26
24PACKAGECONFIG ??= "translator sqlite monitor python3-probes" 27PACKAGECONFIG ??= "translator sqlite monitor python3-probes ${@bb.utils.filter('DISTRO_FEATURES', 'debuginfod', d)}"
25PACKAGECONFIG[translator] = "--enable-translator,--disable-translator,boost,bash" 28PACKAGECONFIG[translator] = "--enable-translator,--disable-translator,boost,bash"
26PACKAGECONFIG[libvirt] = "--enable-libvirt,--disable-libvirt,libvirt" 29PACKAGECONFIG[libvirt] = "--enable-libvirt,--disable-libvirt,libvirt"
27PACKAGECONFIG[sqlite] = "--enable-sqlite,--disable-sqlite,sqlite3" 30PACKAGECONFIG[sqlite] = "--enable-sqlite,--disable-sqlite,sqlite3"
28PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor,ncurses json-c" 31PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor,ncurses json-c"
29PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,python3-setuptools-native" 32PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,python3-setuptools-native"
33PACKAGECONFIG[debuginfod] = "--with-debuginfod, --without-debuginfod"
30 34
31inherit autotools gettext pkgconfig systemd 35inherit autotools gettext pkgconfig systemd
32inherit ${@bb.utils.contains('PACKAGECONFIG', 'python3-probes', 'distutils3-base', '', d)} 36inherit_defer ${@bb.utils.contains('PACKAGECONFIG', 'python3-probes', 'setuptools3-base', '', d)}
37
38# | ../git/elaborate.cxx:2601:21: error: storing the address of local variable 'sym' in '*s.systemtap_session::symbol_resolver' [-Werror=dangling-pointer=]
39CXXFLAGS += "-Wno-dangling-pointer"
33 40
34# exporter comes with python3-probes 41# exporter comes with python3-probes
35PACKAGES =+ "${PN}-exporter" 42PACKAGES =+ "${PN}-exporter"
36FILES_${PN}-exporter = "${sysconfdir}/stap-exporter/* \ 43FILES:${PN}-exporter = "${sysconfdir}/stap-exporter/* \
37 ${sysconfdir}/sysconfig/stap-exporter \ 44 ${sysconfdir}/sysconfig/stap-exporter \
38 ${systemd_unitdir}/system/stap-exporter.service \ 45 ${systemd_system_unitdir}/stap-exporter.service \
39 ${sbindir}/stap-exporter" 46 ${sbindir}/stap-exporter"
40RDEPENDS_${PN}-exporter = "${PN} python3-core python3-netclient" 47RDEPENDS:${PN}-exporter = "${PN} python3-core python3-netclient"
41SYSTEMD_SERVICE_${PN}-exporter = "stap-exporter.service" 48SYSTEMD_SERVICE:${PN}-exporter = "stap-exporter.service"
42 49
43PACKAGES =+ "${PN}-runtime" 50PACKAGES =+ "${PN}-runtime"
44FILES_${PN}-runtime = "\ 51FILES:${PN}-runtime = "\
45 ${bindir}/staprun \ 52 ${bindir}/staprun \
46 ${bindir}/stap-merge \ 53 ${bindir}/stap-merge \
47 ${bindir}/stapsh \ 54 ${bindir}/stapsh \
48 ${libexecdir}/${BPN}/stapio \ 55 ${libexecdir}/${BPN}/stapio \
49" 56"
50RDEPENDS_${PN}_class-target += "${PN}-runtime" 57RDEPENDS:${PN}:class-target += "${PN}-runtime"
51 58
52PACKAGES =+ "${PN}-examples" 59PACKAGES =+ "${PN}-examples"
53FILES_${PN}-examples = "${datadir}/${BPN}/examples/" 60FILES:${PN}-examples = "${datadir}/${BPN}/examples/"
54RDEPENDS_${PN}-examples += "${PN}" 61RDEPENDS:${PN}-examples += "${PN}"
55 62
56# don't complain that some examples involve bash, perl, php... 63# don't complain that some examples involve bash, perl, php...
57INSANE_SKIP_${PN}-examples += "file-rdeps" 64INSANE_SKIP:${PN}-examples += "file-rdeps"
58 65
59PACKAGES =+ "${PN}-python" 66PACKAGES =+ "${PN}-python"
60FILES_${PN}-python += "\ 67FILES:${PN}-python += "\
61 ${bindir}/dtrace \ 68 ${bindir}/dtrace \
62 ${libdir}/python*/ \ 69 ${libdir}/python*/ \
63 ${libexecdir}/${BPN}/python/ \ 70 ${libexecdir}/${BPN}/python/ \
64" 71"
65# python material requires sdt headers 72# python material requires sdt headers
66RDEPENDS_${PN}-python += "${PN}-dev python3-core" 73RDEPENDS:${PN}-python += "${PN}-dev python3-core"
67INSANE_SKIP_${PN}-python += "dev-deps" 74INSANE_SKIP:${PN}-python += "dev-deps"
68 75
69do_configure_prepend () { 76do_configure:prepend () {
70 # Improve reproducibility for c++ object files 77 # Improve reproducibility for c++ object files
71 reltivepath="${@os.path.relpath(d.getVar('STAGING_INCDIR'), d.getVar('S'))}" 78 reltivepath="${@os.path.relpath(d.getVar('STAGING_INCDIR'), d.getVar('S'))}"
72 sed -i "s:@RELATIVE_STAGING_INCDIR@:$reltivepath:g" ${S}/stringtable.h 79 sed -i "s:@RELATIVE_STAGING_INCDIR@:$reltivepath:g" ${S}/stringtable.h
73} 80}
74 81
75do_install_append () { 82do_install:append () {
76 if [ ! -f ${D}${bindir}/stap ]; then 83 if [ ! -f ${D}${bindir}/stap ]; then
77 # translator disabled case, need to leave only minimal runtime 84 # translator disabled case, need to leave only minimal runtime
78 rm -rf ${D}${datadir}/${PN} 85 rm -rf ${D}${datadir}/${PN}