summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_2.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_2.6.1.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_2.6.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_2.6.1.bb b/meta/recipes-kernel/powertop/powertop_2.6.1.bb
new file mode 100644
index 0000000000..ddb510254a
--- /dev/null
+++ b/meta/recipes-kernel/powertop/powertop_2.6.1.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Power usage tool"
2DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
3HOMEPAGE = "http://01.org/powertop/"
4BUGTRACKER = "http://bugzilla.lesswatts.org/"
5DEPENDS = "ncurses libnl pciutils"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
9SRC_URI = "http://01.org/powertop/sites/default/files/downloads/powertop-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "4391e7b0af854ecf722cdf712f24b631"
12SRC_URI[sha256sum] = "034cde6d5bb433fe0d29251d5cde5d4c2948abf05fe29ef10966b659331b20e4"
13
14inherit autotools gettext pkgconfig
15
16# we need to explicitly link with libintl in uClibc systems
17EXTRA_LDFLAGS ?= ""
18EXTRA_LDFLAGS_libc-uclibc = "-lintl"
19LDFLAGS += "${EXTRA_LDFLAGS}"
20
21# we do not want libncursesw if we can
22do_configure_prepend() {
23 # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
24 sed -i -e "s/ncursesw//g" ${S}/configure.ac
25 mkdir -p ${B}/src/tuning/
26}
27
28inherit update-alternatives
29ALTERNATIVE_${PN} = "powertop"
30ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
31ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop"
32ALTERNATIVE_PRIORITY = "100"