summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_2.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_2.13.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_2.13.bb32
1 files changed, 0 insertions, 32 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_2.13.bb b/meta/recipes-kernel/powertop/powertop_2.13.bb
deleted file mode 100644
index 8c7e78fd94..0000000000
--- a/meta/recipes-kernel/powertop/powertop_2.13.bb
+++ /dev/null
@@ -1,32 +0,0 @@
1SUMMARY = "Power usage tool"
2DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
3HOMEPAGE = "https://01.org/powertop/"
4BUGTRACKER = "https://app.devzing.com/powertopbugs/bugzilla"
5DEPENDS = "ncurses libnl pciutils autoconf-archive"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
9SRC_URI = "git://github.com/fenrus75/powertop;protocol=https \
10 file://0001-wakeup_xxx.h-include-limits.h.patch \
11"
12SRCREV = "184cee06b2d64679bae5f806fe0a218827fdde99"
13
14S = "${WORKDIR}/git"
15
16inherit autotools gettext pkgconfig bash-completion
17
18# we do not want libncursesw if we can
19do_configure_prepend() {
20 # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
21 sed -i -e "s/ncursesw//g" ${S}/configure.ac
22 mkdir -p ${B}/src/tuning/
23 echo "${PV}" > ${S}/version-long
24 echo "${PV}" > ${S}/version-short
25 cp ${STAGING_DATADIR}/aclocal/ax_require_defined.m4 ${S}/m4/
26}
27
28inherit update-alternatives
29ALTERNATIVE_${PN} = "powertop"
30ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
31ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop"
32ALTERNATIVE_PRIORITY = "100"