summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf/perf.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r--meta/recipes-kernel/perf/perf.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index ae7e24aa0c..6c4ee4a208 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -230,14 +230,18 @@ do_configure:prepend () {
230 if [ -e "${S}/tools/perf/Makefile.perf" ]; then 230 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
231 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \ 231 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
232 ${S}/tools/perf/Makefile.perf 232 ${S}/tools/perf/Makefile.perf
233 # Variant with linux-yocto-specific patch
233 sed -i -e "s,prefix='\$(DESTDIR_SQ)/usr'$,prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(PYTHON_SITEPACKAGES_DIR)' --root='\$(DESTDIR)',g" \ 234 sed -i -e "s,prefix='\$(DESTDIR_SQ)/usr'$,prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(PYTHON_SITEPACKAGES_DIR)' --root='\$(DESTDIR)',g" \
234 ${S}/tools/perf/Makefile.perf 235 ${S}/tools/perf/Makefile.perf
236 # Variant for mainline Linux
237 sed -i -e "s,root='/\$(DESTDIR_SQ)',prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(PYTHON_SITEPACKAGES_DIR)' --root='/\$(DESTDIR_SQ)',g" \
238 ${S}/tools/perf/Makefile.perf
235 # backport https://github.com/torvalds/linux/commit/e4ffd066ff440a57097e9140fa9e16ceef905de8 239 # backport https://github.com/torvalds/linux/commit/e4ffd066ff440a57097e9140fa9e16ceef905de8
236 sed -i -e 's,\($(Q)$(SHELL) .$(arch_errno_tbl).\) $(CC) $(arch_errno_hdr_dir),\1 $(firstword $(CC)) $(arch_errno_hdr_dir),g' \ 240 sed -i -e 's,\($(Q)$(SHELL) .$(arch_errno_tbl).\) $(CC) $(arch_errno_hdr_dir),\1 $(firstword $(CC)) $(arch_errno_hdr_dir),g' \
237 ${S}/tools/perf/Makefile.perf 241 ${S}/tools/perf/Makefile.perf
238 fi 242 fi
239 sed -i -e "s,--root='/\$(DESTDIR_SQ)',--prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \ 243 sed -i -e "s,--root='/\$(DESTDIR_SQ)',--prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \
240 ${S}/tools/perf/Makefile* 244 ${S}/tools/perf/Makefile
241 245
242 if [ -e "${S}/tools/build/Makefile.build" ]; then 246 if [ -e "${S}/tools/build/Makefile.build" ]; then
243 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \ 247 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \