summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf/perf.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r--meta/recipes-kernel/perf/perf.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 3771cdb3e9..d375e246ce 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -22,7 +22,7 @@ TUI_DEPENDS = "${@perf_feature_enabled('perf-tui', 'libnewt slang', '',d)}"
22SCRIPTING_DEPENDS = "${@perf_feature_enabled('perf-scripting', 'perl python', '',d)}" 22SCRIPTING_DEPENDS = "${@perf_feature_enabled('perf-scripting', 'perl python', '',d)}"
23LIBUNWIND_DEPENDS = "${@perf_feature_enabled('perf-libunwind', 'libunwind', '',d)}" 23LIBUNWIND_DEPENDS = "${@perf_feature_enabled('perf-libunwind', 'libunwind', '',d)}"
24 24
25DEPENDS = "virtual/kernel \ 25DEPENDS = " \
26 virtual/${MLPREFIX}libc \ 26 virtual/${MLPREFIX}libc \
27 ${MLPREFIX}elfutils \ 27 ${MLPREFIX}elfutils \
28 ${MLPREFIX}binutils \ 28 ${MLPREFIX}binutils \
@@ -32,6 +32,8 @@ DEPENDS = "virtual/kernel \
32 bison flex \ 32 bison flex \
33" 33"
34 34
35do_configure[depends] += "virtual/kernel:do_patch"
36
35PROVIDES = "virtual/perf" 37PROVIDES = "virtual/perf"
36 38
37inherit linux-kernel-base kernel-arch pythonnative 39inherit linux-kernel-base kernel-arch pythonnative
@@ -46,7 +48,7 @@ export HOST_SYS
46#kernel 3.1+ supports WERROR to disable warnings as errors 48#kernel 3.1+ supports WERROR to disable warnings as errors
47export WERROR = "0" 49export WERROR = "0"
48 50
49do_populate_lic[depends] += "virtual/kernel:do_populate_sysroot" 51do_populate_lic[depends] += "virtual/kernel:do_patch"
50 52
51# needed for building the tools/perf Perl binding 53# needed for building the tools/perf Perl binding
52inherit perlnative cpan-base 54inherit perlnative cpan-base
@@ -56,9 +58,7 @@ export PERL_INC = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/${@get_perl_version(d)}
56export PERL_LIB = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/${@get_perl_version(d)}" 58export PERL_LIB = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/${@get_perl_version(d)}"
57export PERL_ARCHLIB = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/${@get_perl_version(d)}" 59export PERL_ARCHLIB = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/${@get_perl_version(d)}"
58 60
59S = "${STAGING_KERNEL_DIR}" 61inherit kernelsrc
60# The source should be ready after the do_unpack
61do_unpack[depends] += "virtual/kernel:do_populate_sysroot"
62 62
63B = "${WORKDIR}/${BPN}-${PV}" 63B = "${WORKDIR}/${BPN}-${PV}"
64 64
@@ -157,7 +157,7 @@ do_configure_prepend () {
157} 157}
158 158
159python do_package_prepend() { 159python do_package_prepend() {
160 bb.data.setVar('PKGV', get_kernelversion('${S}').split("-")[0], d) 160 d.setVar('PKGV', d.getVar("KERNEL_VERSION", True).split("-")[0])
161} 161}
162 162
163PACKAGE_ARCH = "${MACHINE_ARCH}" 163PACKAGE_ARCH = "${MACHINE_ARCH}"