summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf/perf.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r--meta/recipes-kernel/perf/perf.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 2beb404c03..c7653e523c 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -250,6 +250,14 @@ do_configure_prepend () {
250 # all the calls have YFLAGS, which contains prefix mapping information. 250 # all the calls have YFLAGS, which contains prefix mapping information.
251 sed -i -e 's,$(YACC),$(YACC) $(YFLAGS),g' ${S}/scripts/Makefile.host 251 sed -i -e 's,$(YACC),$(YACC) $(YFLAGS),g' ${S}/scripts/Makefile.host
252 fi 252 fi
253 if [ -e "${S}/tools/perf/pmu-events/Build" ]; then
254 target='$(OUTPUT)pmu-events/pmu-events.c $(V)'
255 replacement1='$(OUTPUT)pmu-events/pmu-events.c $(V)\n'
256 replacement2='\t$(srctree)/sort-pmuevents.py $(OUTPUT)pmu-events/pmu-events.c $(OUTPUT)pmu-events/pmu-events.c.new\n'
257 replacement3='\tcp $(OUTPUT)pmu-events/pmu-events.c.new $(OUTPUT)pmu-events/pmu-events.c'
258 sed -i -e "s,$target,$replacement1$replacement2$replacement3,g" \
259 "${S}/tools/perf/pmu-events/Build"
260 fi
253 # end reproducibility substitutions 261 # end reproducibility substitutions
254 262
255 # We need to ensure the --sysroot option in CC is preserved 263 # We need to ensure the --sysroot option in CC is preserved
@@ -292,6 +300,14 @@ do_configure_prepend () {
292 # so we copy it from the sysroot unistd.h to the perf unistd.h 300 # so we copy it from the sysroot unistd.h to the perf unistd.h
293 install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/tools/include/uapi/asm-generic/unistd.h 301 install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/tools/include/uapi/asm-generic/unistd.h
294 install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/include/uapi/asm-generic/unistd.h 302 install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/include/uapi/asm-generic/unistd.h
303
304 # the fetcher is inhibited by the 'inherit kernelsrc', so we do a quick check and
305 # copy for a helper script we need
306 for p in $(echo ${FILESPATH} | tr ':' '\n'); do
307 if [ -e $p/sort-pmuevents.py ]; then
308 cp $p/sort-pmuevents.py ${S}
309 fi
310 done
295} 311}
296 312
297python do_package_prepend() { 313python do_package_prepend() {