summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf/perf.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r--meta/recipes-kernel/perf/perf.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 1dff39a17e..2f28d16fba 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -360,6 +360,16 @@ FILES:${PN}-python = " \
360 " 360 "
361FILES:${PN}-perl = "${libexecdir}/perf-core/scripts/perl" 361FILES:${PN}-perl = "${libexecdir}/perf-core/scripts/perl"
362 362
363
364INHIBIT_PACKAGE_DEBUG_SPLIT="1"
365DEBUG_OPTIMIZATION:append = " -Wno-error=maybe-uninitialized" 363DEBUG_OPTIMIZATION:append = " -Wno-error=maybe-uninitialized"
364
365PACKAGESPLITFUNCS =+ "perf_fix_sources"
366
367perf_fix_sources () {
368 for f in util/parse-events-flex.h util/parse-events-flex.c util/pmu-flex.c \
369 util/expr-flex.h util/expr-flex.c; do
370 f=${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/$f
371 if [ -e $f ]; then
372 sed -i -e 's#${S}/##g' $f
373 fi
374 done
375}