summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/oprofile/oprofileui-server_git.bb')
-rw-r--r--meta/recipes-kernel/oprofile/oprofileui-server_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-kernel/oprofile/oprofileui-server_git.bb b/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
new file mode 100644
index 0000000000..dbb559965a
--- /dev/null
+++ b/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
@@ -0,0 +1,32 @@
1require oprofileui.inc
2
3SRCREV = "f168b8bfdc63660033de1739c6ddad1abd97c379"
4PV = "0.0+git${SRCPV}"
5
6S = "${WORKDIR}/git"
7
8SRC_URI = "git://git.yoctoproject.org/oprofileui \
9 file://init \
10 file://oprofileui-server.service "
11
12EXTRA_OECONF += "--disable-client --enable-server"
13
14RDEPENDS_${PN} = "oprofile"
15
16do_install_append() {
17 install -d ${D}${sysconfdir}/init.d
18 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/oprofileui-server
19
20 install -d ${D}${systemd_unitdir}/system
21 install -m 0644 ${WORKDIR}/oprofileui-server.service ${D}${systemd_unitdir}/system/
22 sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' \
23 -e 's,@BINDIR@,${bindir},g' ${D}${systemd_unitdir}/system/oprofileui-server.service
24}
25
26inherit update-rc.d systemd
27
28INITSCRIPT_NAME = "oprofileui-server"
29INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
30
31SYSTEMD_SERVICE_${PN} = "oprofileui-server.service"
32SYSTEMD_AUTO_ENABLE = "disable"