summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/oprofile/oprofileui-server_git.bb')
-rw-r--r--meta/recipes-kernel/oprofile/oprofileui-server_git.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/meta/recipes-kernel/oprofile/oprofileui-server_git.bb b/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
index b9f6a811e5..e75923f2a3 100644
--- a/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
+++ b/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
@@ -6,8 +6,19 @@ PR = "r0"
6 6
7S = "${WORKDIR}/git" 7S = "${WORKDIR}/git"
8 8
9SRC_URI = "git://git.yoctoproject.org/oprofileui;protocol=git" 9SRC_URI = "git://git.yoctoproject.org/oprofileui;protocol=git \
10 file://init"
10 11
11EXTRA_OECONF += "--disable-client --enable-server" 12EXTRA_OECONF += "--disable-client --enable-server"
12 13
13RDEPENDS_${PN} = "oprofile" 14RDEPENDS_${PN} = "oprofile"
15
16do_install_append() {
17 install -d ${D}${sysconfdir}/init.d
18 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/oprofileui-server
19}
20
21INITSCRIPT_NAME = "oprofileui-server"
22INITSCRIPT_PARAMS = "start 999 5 2 . stop 20 0 1 6 ."
23
24inherit update-rc.d