summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/oprofile/oprofileui-server_git.bb')
-rw-r--r--meta/recipes-kernel/oprofile/oprofileui-server_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-kernel/oprofile/oprofileui-server_git.bb b/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
new file mode 100644
index 0000000000..eb3b78b906
--- /dev/null
+++ b/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
@@ -0,0 +1,34 @@
1require oprofileui.inc
2
3SRCREV = "389e1875af4721d52c7e65cf9cfffb69b0ed6a59"
4PV = "0.0+git${SRCPV}"
5
6S = "${WORKDIR}/git"
7
8SRC_URI = "git://git.yoctoproject.org/oprofileui \
9 file://init \
10 file://oprofileui-server.service "
11
12DEPENDS += "intltool-native"
13
14EXTRA_OECONF += "--disable-client --enable-server"
15
16RDEPENDS_${PN} = "oprofile avahi-daemon"
17
18do_install_append() {
19 install -d ${D}${sysconfdir}/init.d
20 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/oprofileui-server
21
22 install -d ${D}${systemd_unitdir}/system
23 install -m 0644 ${WORKDIR}/oprofileui-server.service ${D}${systemd_unitdir}/system/
24 sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' \
25 -e 's,@BINDIR@,${bindir},g' ${D}${systemd_unitdir}/system/oprofileui-server.service
26}
27
28inherit update-rc.d systemd
29
30INITSCRIPT_NAME = "oprofileui-server"
31INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
32
33SYSTEMD_SERVICE_${PN} = "oprofileui-server.service"
34SYSTEMD_AUTO_ENABLE = "disable"