summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb')
-rw-r--r--meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb b/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
index 92ffa4720e..a91680d497 100644
--- a/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
+++ b/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
@@ -1,9 +1,9 @@
1SUMMARY = "Build tools needed by external modules" 1SUMMARY = "Build tools needed by external modules"
2HOMEPAGE = "https://www.yoctoproject.org/" 2HOMEPAGE = "https://www.yoctoproject.org/"
3LICENSE = "GPLv2" 3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6" 4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
5 5
6inherit kernel-arch 6inherit kernel-arch linux-kernel-base
7inherit pkgconfig 7inherit pkgconfig
8 8
9PACKAGE_ARCH = "${MACHINE_ARCH}" 9PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -13,13 +13,16 @@ S = "${WORKDIR}"
13do_configure[depends] += "virtual/kernel:do_shared_workdir openssl-native:do_populate_sysroot" 13do_configure[depends] += "virtual/kernel:do_shared_workdir openssl-native:do_populate_sysroot"
14do_compile[depends] += "virtual/kernel:do_compile_kernelmodules" 14do_compile[depends] += "virtual/kernel:do_compile_kernelmodules"
15 15
16RDEPENDS_${PN}-dev = "" 16DEV_PKG_DEPENDENCY = ""
17 17
18DEPENDS += "bc-native bison-native" 18DEPENDS += "bc-native bison-native"
19DEPENDS += "gmp-native" 19DEPENDS += "gmp-native"
20 20
21EXTRA_OEMAKE = " HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCPP="${BUILD_CPP}"" 21EXTRA_OEMAKE = " HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCPP="${BUILD_CPP}""
22EXTRA_OEMAKE += " HOSTCXX="${BUILD_CXX} ${BUILD_CXXFLAGS} ${BUILD_LDFLAGS}"" 22EXTRA_OEMAKE += " HOSTCXX="${BUILD_CXX} ${BUILD_CXXFLAGS} ${BUILD_LDFLAGS}" CROSS_COMPILE=${TARGET_PREFIX}"
23
24KERNEL_LOCALVERSION = "${@get_kernellocalversion_file("${STAGING_KERNEL_BUILDDIR}")}"
25export LOCALVERSION="${KERNEL_LOCALVERSION}"
23 26
24# Build some host tools under work-shared. CC, LD, and AR are probably 27# Build some host tools under work-shared. CC, LD, and AR are probably
25# not used, but this is the historical way of invoking "make scripts". 28# not used, but this is the historical way of invoking "make scripts".
@@ -27,7 +30,9 @@ EXTRA_OEMAKE += " HOSTCXX="${BUILD_CXX} ${BUILD_CXXFLAGS} ${BUILD_LDFLAGS}""
27do_configure() { 30do_configure() {
28 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS 31 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
29 for t in prepare scripts_basic scripts; do 32 for t in prepare scripts_basic scripts; do
30 oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" AR="${KERNEL_AR}" \ 33 oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
34 AR="${KERNEL_AR}" OBJCOPY="${KERNEL_OBJCOPY}" \
35 STRIP="${KERNEL_STRIP}" \
31 -C ${STAGING_KERNEL_DIR} O=${STAGING_KERNEL_BUILDDIR} $t 36 -C ${STAGING_KERNEL_DIR} O=${STAGING_KERNEL_BUILDDIR} $t
32 done 37 done
33} 38}