summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-ust_2.10.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-ust_2.10.2.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-ust_2.10.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-ust_2.10.2.bb b/meta/recipes-kernel/lttng/lttng-ust_2.10.2.bb
new file mode 100644
index 0000000000..3e5f37d886
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-ust_2.10.2.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Linux Trace Toolkit Userspace Tracer 2.x"
2DESCRIPTION = "The LTTng UST 2.x package contains the userspace tracer library to trace userspace codes."
3HOMEPAGE = "http://lttng.org/ust"
4BUGTRACKER = "https://bugs.lttng.org/projects/lttng-ust"
5
6LICENSE = "LGPLv2.1+ & MIT & GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c963eb366b781252b0bf0fdf1624d9e9 \
8 file://snprintf/snprintf.c;endline=32;md5=d3d544959d8a3782b2e07451be0a903c \
9 file://snprintf/various.h;endline=31;md5=89f2509b6b4682c4fc95255eec4abe44"
10
11inherit autotools lib_package manpages
12
13DEPENDS = "liburcu util-linux"
14RDEPENDS_${PN}-bin = "python3-core"
15
16# For backwards compatibility after rename
17RPROVIDES_${PN} = "lttng2-ust"
18RREPLACES_${PN} = "lttng2-ust"
19RCONFLICTS_${PN} = "lttng2-ust"
20
21PE = "2"
22
23SRC_URI = "https://lttng.org/files/lttng-ust/lttng-ust-${PV}.tar.bz2 \
24 file://lttng-ust-doc-examples-disable.patch \
25 "
26SRC_URI[md5sum] = "a95333f76e2986113154b8193f5cfca3"
27SRC_URI[sha256sum] = "c4ca22b904eb08817b313a73d499e1b217ffee1f862156d0d52865317486c045"
28
29CVE_PRODUCT = "ust"
30
31PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages, asciidoc-native xmlto-native libxslt-native"
32
33do_install_append() {
34 # Patch python tools to use Python 3; they should be source compatible, but
35 # still refer to Python 2 in the shebang
36 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${bindir}/lttng-gen-tp
37}