summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.5.0.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.5.0.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.5.0.bb b/meta/recipes-kernel/lttng/lttng-modules_2.5.0.bb
new file mode 100644
index 0000000000..1a352209ed
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.5.0.bb
@@ -0,0 +1,44 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1412caf5a1aa90d6a48588a4794c0eac \
6 file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
7 file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
8
9DEPENDS = "virtual/kernel"
10
11inherit module
12
13SRCREV = "789fd1d06d07aeb9a403bdce1b3318560cfc6eca"
14
15COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|arm).*-linux'
16
17SRC_URI = "git://git.lttng.org/lttng-modules.git;branch=stable-2.5 \
18 file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch \
19 file://Update-compaction-instrumentation-to-3.16-kernel.patch \
20 file://Update-vmscan-instrumentation-to-3.16-kernel.patch \
21 file://lttng-modules-remove-kernel-version-check.patch \
22 file://Fix-noargs-probes-should-calculate-alignment-and-eve.patch \
23 file://Update-statedump-to-3.17-nsproxy-locking.patch \
24 file://Update-kvm-instrumentation-compile-on-3.17-rc1.patch \
25 file://fix_build_with_v3.17_kernel.patch \
26 file://compaction-fix-mm_compaction_isolate_template-build.patch \
27 "
28
29export INSTALL_MOD_DIR="kernel/lttng-modules"
30export KERNEL_SRC="${STAGING_KERNEL_DIR}"
31
32
33S = "${WORKDIR}/git"
34
35do_install_append() {
36 # Delete empty directories to avoid QA failures if no modules were built
37 find ${D}/lib -depth -type d -empty -exec rmdir {} \;
38}
39
40python do_package_prepend() {
41 if not os.path.exists(os.path.join(d.getVar('D', True), 'lib/modules')):
42 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN', True))
43}
44