summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.13.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.13.5.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.13.5.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.13.5.bb b/meta/recipes-kernel/lttng/lttng-modules_2.13.5.bb
new file mode 100644
index 0000000000..00095d6ab7
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.13.5.bb
@@ -0,0 +1,42 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4HOMEPAGE = "https://lttng.org/"
5LICENSE = "LGPL-2.1-only & GPL-2.0-only & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=0464cff101a009c403cd2ed65d01d4c4"
7
8inherit module
9
10include lttng-platforms.inc
11
12SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
13 file://0009-Rename-genhd-wrapper-to-blkdev.patch \
14 "
15
16# Use :append here so that the patch is applied also when using devupstream
17SRC_URI:append = " file://0001-src-Kbuild-change-missing-CONFIG_TRACEPOINTS-to-warn.patch"
18
19SRC_URI[sha256sum] = "eceb3428d80e85a9f008425beb9526195c9f7f02b302f28add56df53aef3e708"
20
21export INSTALL_MOD_DIR="kernel/lttng-modules"
22
23EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
24
25MODULES_MODULE_SYMVERS_LOCATION = "src"
26
27do_install:append() {
28 # Delete empty directories to avoid QA failures if no modules were built
29 if [ -d ${D}/${nonarch_base_libdir} ]; then
30 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
31 fi
32}
33
34python do_package:prepend() {
35 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
36 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
37}
38
39BBCLASSEXTEND = "devupstream:target"
40SRC_URI:class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.13"
41SRCREV:class-devupstream = "7584cfc04914cb0842a986e9808686858b9c8630"
42SRCREV_FORMAT ?= "lttng_git"