summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.12.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.12.4.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.12.4.bb41
1 files changed, 0 insertions, 41 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.12.4.bb b/meta/recipes-kernel/lttng/lttng-modules_2.12.4.bb
deleted file mode 100644
index 3ca59f789a..0000000000
--- a/meta/recipes-kernel/lttng/lttng-modules_2.12.4.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4HOMEPAGE = "https://lttng.org/"
5LICENSE = "LGPLv2.1 & GPLv2 & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
7
8inherit module
9
10include lttng-platforms.inc
11
12SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
13 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
14 "
15
16SRC_URI[sha256sum] = "fe66400fa1b85bff1b9ae24419c74e3bb7d358d643eade0594d81b48bd190688"
17
18export INSTALL_MOD_DIR="kernel/lttng-modules"
19
20EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
21
22do_install_append() {
23 # Delete empty directories to avoid QA failures if no modules were built
24 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
25}
26
27python do_package_prepend() {
28 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
29 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
30}
31
32BBCLASSEXTEND = "devupstream:target"
33LIC_FILES_CHKSUM_class-devupstream = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
34DEFAULT_PREFERENCE_class-devupstream = "-1"
35SRC_URI_class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.12 \
36 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
37 "
38SRCREV_class-devupstream = "be71b60a327d7ad2588abc5cad2861177119972b"
39PV_class-devupstream = "2.12.3+git${SRCPV}"
40S_class-devupstream = "${WORKDIR}/git"
41SRCREV_FORMAT ?= "lttng_git"